distal-attribute
distal-attribute
distal-attribute
distal-attribute

Terrible bug in Heidi 7.0.0.4

User, date Message
Written by abiku
1 year ago
Category: General
1 posts since Mon, 26 Nov 12
Was working with Heidi last few days , testing it.
Unofortunatelly i had to uninstall it from my computer as i just lost my whole DB i was working on last 2 days :(
I was trying to export this DB to sql file but i didn't notice that i set as an output exactly the same DB...
Of course it was my fault i didn't notice this but Heidi should have given me some error, information or whatever but instead it deleted all tables from the exported db!

Written by ansgar
1 year ago
4784 posts since Fri, 07 Apr 06
Oh shit, that's really bad.

What exactly did you select in the "Output" drop down? I could imagine it was "Database", and you checked "DROP tables", and "DELETE + INSERT data"?

The DROP checkboxes alreaday have an exclamation mark and are formatted in bold as soon as you check them. But I guess it makes sens to alert the user if any of the two "DROP" checkboxes are checked, before the actual export starts.
Written by ansgar
1 year ago
4784 posts since Fri, 07 Apr 06
You mentioned a "bug" - what exactly makes you think this is a bug?
Written by combuilder
1 year ago
30 posts since Thu, 08 Nov 12
I think he can tell you check that the FROM and TO database don't be the same!
Written by ansgar
1 year ago
4784 posts since Fri, 07 Apr 06
Yes, if that was what abiku did - that's why I asked for settings.
 

Please login to leave a reply, or register at first.