distal-attribute
distal-attribute
distal-attribute
distal-attribute

HeidiSQL SSH

User, date Message
Written by abnormality
1 year ago
Category: General
3 posts since Wed, 30 Jan 13
Hello guys, I've tried connecting to my SQL server using HeidiSQL. The SQL server only accepts connections from localhost so I have to SSH into it and then connect. When I connect normally using Putty and then mysql -h 127.0.0.1 -u -p it works perfectly. My steps:

When trying to use HeidiSQL I set network type to MySQL(SSH TUNNEL).
(ssh tunnel tab)Set plink location, set ssh host and port, set ssh username and password, leave the rest as is.
(settings tab)hostname/ip i've tried putting 127.0.0.1 and host of sql server. user and password I fill with SQL credentials and I'm getting errors that it says it can't connect to localhost. Any help? thank you!
Written by ansgar
1 year ago
4783 posts since Fri, 07 Apr 06
In the settings tab, do not use 127.0.0.1, but the real host ip/name. In the SSH tunnel tab, do not enter any ip/host.

Then, ensure you have plink.exe specified, and it's not red (= can't find the path).
Written by abnormality
1 year ago
3 posts since Wed, 30 Jan 13
I'm getting host 'xxxxx' is not allowed to connect to this MySQL server.
Written by ansgar
1 year ago
4783 posts since Fri, 07 Apr 06
Can you post the plink command line here, which HeidiSQL creates? Be sure the password is obscured. To see the command line, you will need one successful connection to any server, and the SQL log visible. Then, click File > Session manager, and try the SSH connection. The plink.exe command line should be visible in the SQL log afterwards.
Written by abnormality
1 year ago
3 posts since Wed, 30 Jan 13
Worked great now. I think it was because of my firewall. Although I CLEARLY stated that I wanted to allow it, that seemed to be the problem. Thank you!
Written by ansgar
1 year ago
4783 posts since Fri, 07 Apr 06
Super! Thanks for the feedback.
 

Please login to leave a reply, or register at first.