distal-attribute
distal-attribute
distal-attribute
distal-attribute

Crash due to data

BubikolRamios posted 1 year ago in General
Send you a mail , also try to edit in data tab - column #9 not available.

Doh, as you can see from mail, data can be exported to clipboard normaly with heidi sql (export as sql).
ansgar posted 1 year ago
Please do not send me private mails. The forum is the place to post something. If you have attachments, please upload them on some upload service and drop a link here.

In this special case you are even saying the export is fine - so why send it at all?

Could it be you have just deselected the column #9 in the data grid? Click the "Columns" button on the upper right to check that.
ansgar posted 1 year ago
And please update to the latest build before reporting errors. You were using the 8.1 release, which is already some months old. The current build has ~120 newer revisions/modifications already.
BubikolRamios posted 1 year ago
OK, noted.

Here you have, only one row of data that looks normal, no strange characters, double click on that row or left click there (on that row) in data tab.

-- --------------------------------------------------------
-- Host:
-- Server version: 5.1.59-community-log - MySQL Community Server (GPL)
-- Server OS: pc-linux-gnu
-- HeidiSQL Version: 8.1.0.4545
-- --------------------------------------------------------

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET NAMES utf8 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;

-- Dumping structure for table test._t
CREATE TABLE IF NOT EXISTS `_t` (
`term` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`habitus` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`Field2` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`max_height_cm` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`max_width_cm` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`usda_min` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`usda_max` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`exposure` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`watter` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL,
`flowering",` varchar(255) COLLATE utf8_slovenian_ci DEFAULT NULL
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_slovenian_ci;

-- Dumping data for table test._t: 1 rows
DELETE FROM `_t`;
/*!40000 ALTER TABLE `_t` DISABLE KEYS */;
INSERT INTO `_t` (`term`, `habitus`, `Field2`, `max_height_cm`, `max_width_cm`, `usda_min`, `usda_max`, `exposure`, `watter`, `flowering",`) VALUES
('Abelia', 'shrub', 'perennial', '600', '600', '', '', 'sun', 'moderate', '');
/*!40000 ALTER TABLE `_t` ENABLE KEYS */;
/*!40101 SET SQL_MODE=IFNULL(@OLD_SQL_MODE, '') */;
/*!40014 SET FOREIGN_KEY_CHECKS=IF(@OLD_FOREIGN_KEY_CHECKS IS NULL, 1, @OLD_FOREIGN_KEY_CHECKS) */;
/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;

BubikolRamios posted 1 year ago

-- HeidiSQL Version: 8.1.0.4545



Mybe it would be good if there would be 64 bit info too.

BubikolRamios posted 1 year ago
Noted in upper code:

`flowering",`



should be

`flowering`



Hmm, don't know what is that, something is there and heidi sql pick it up at export ...
ansgar posted 1 year ago
That's the problem. You should fix that column name by hand:

ALTER TABLE `_t`
CHANGE COLUMN `flowering",` `flowering` VARCHAR(255) NULL DEFAULT NULL COLLATE 'utf8_slovenian_ci' AFTER `exposure`;

Please login to leave a reply, or register at first.