distal-attribute
distal-attribute
distal-attribute
distal-attribute

Remember settings in SQL export window

kodlik posted 9 months ago in General
Hi.

I would like to ask if there were some changes in the behavior of the SQL export window. Now it doesn't "remember" last settings and offer output to a single file.

I'm quite sure that 8.1.xx version behaved differently.

I get through the options and I couldn't find any clue.

Is there a way how to change the behavior by myself?

Thanks for answer.
ansgar posted 9 months ago
The output option is only restored if it was not a server. So, when you call the dialog you don't get connected to some probably no longer working server.
kodlik posted 9 months ago
I see, that's exactly my situation, I tried to export to a server.

Is there another way than move to previous version?

I understand that the original behavior was perfect for shooting to own leg ;-)
Program4fun posted 9 months ago
I have the same problem. Before it was perfect. I restore my local tables very often with the original data from server. Now I have always to select the settings to copy it into my local database. I think this is more dangerous to make mistakes.

Thank you for such a great tool!
mbedrac posted 9 months ago
I use export database function a lot and I have to click on Drop setting all the time. All settings should be saved and restored when needed. The same thing with the OK button when I select Drop table. Before it was OK selected by default, now I have to move focus to OK button and press Enter. Please, we all know what we are doing, don't nurse as.

ansgar posted 9 months ago
See issue #3411, and issue #3197.
david.proweb posted 9 months ago
This was changed, as quoted by Ansgar.

I see two reasons:

1. When the server is already marked the HeidiSQL takes a little longer to load dialog, even if you do not necessarily want to use that server (remote server).

2. It also helps to decrease some mistakes due to lack of attention. For example, you rely on your memory and accept exports to the wrong server. Of course, this must be very unusual. But human error can happen.

To solve the first problem and get back to the old behavior, it would be necessary not directly connect to the pre-selected server, only when exporting in fact. The connection should also occur when trying to change the table. I do not know what the difficulty with developing something to that effect, but perhaps pleases both parties.
Program4fun posted 9 months ago
Today it happened, I destroyed a backup file.
Last year (!!!) I saved a database in a .sql-file and the dialog kept this setting. Today I restored many times a local tables from server and one time I forgot to change the output to localhost. By this I overwrote the backup.

Why is there no question: "Are you sure to overwrite?"
david.proweb posted 9 months ago
Relly, make sense to ask in this case.

For now, I suggest you to use this "filename" on your path: %db %date.zip (or .sql)

Like:
C:\Users\YourUser\Desktop\%db %date.zip

About your backup, check if your Windows have a Shadow Copy.
lemon_juice posted 9 months ago
Both the old way and the new way have their pros and cons depending on usage. In the past I didn't like the fact that Heidi automatically connected to some previously used server and either took some time to do it or ended up with an error. Now I don't like the fact that I have to re-select all my export settings.

What would be the solution? My suggestion is to leave the new behaviour as it is but add a button somewhere in the export window "Restore previous export settings". Pressing the button would select all previously used settings including the server/db and the "Drop" checkbox.

(BTW, I use "Drop" 99% of the time and I don't really like to check it manually every time)

kodlik posted 9 months ago
Well, there is to many use cases to satisfy all of us.

It would be nice to have "save as default" button, which would preserve the settings you are using the most.

But I don't see solution for everyone.

Please login to leave a reply, or register at first.