distal-attribute
distal-attribute
distal-attribute
distal-attribute

HeisiSQL Crashing on long query

j.w.jones posted 10 months ago in General
Hi,

I am trying a long query which runs fine when I use the 'mysql' command line tool - it takes approx 6.5 minutes.

In HeidiSQL in runs for a few minutes and then crashes with the following bug report. I have updated to the latest version this morning.

Cheers,

Jason

date/time : 2014-02-26, 12:09:01, 192ms
computer name : ENJJ
user name : cgjones
registered owner : cgjones / Microsoft
operating system : Windows 7 x64 Service Pack 1 build 7601
system language : English
system up time : 4 days 19 hours
program up time : 11 minutes 52 seconds
processors : 8x Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
physical memory : 2595/16267 MB (free/total)
free disk space : (C:) 157.11 GB
display mode : 1920x1200, 32 bit
process id : $1f10
allocated memory : 51.06 MB
largest free block : 8181.40 GB
executable : heidisql.exe
exec. date/time : 2014-01-25 11:34
version : 8.3.0.4694
compiled with : Delphi XE5
madExcept version : 4.0.8.1
callstack crc : $a2fd4c37, $c09a6320, $c09a6320
exception number : 1
exception class : EAccessViolation
exception message : Access violation at address 000007FEDFECCE44 in module 'libmysql.dll'. Read of address 00000000000000C8.

thread $1d48:
7fedfecc libmysql.dll
7fedfec8 libmysql.dll mysql_store_result
00a624e7 heidisql.exe dbconnection 1629 +35 TMySQLConnection.Query
00958583 heidisql.exe helpers 2749 +37 TQueryThread.Execute
004f9b04 heidisql.exe madExcept HookedTThreadExecute
005d4220 heidisql.exe System.Classes ThreadProc
0040f588 heidisql.exe System ThreadWrapper
004f99d9 heidisql.exe madExcept ThreadExceptFrame
7728652b kernel32.dll BaseThreadInitThunk

main thread ($17d0):
00000000 heidisql.exe madStackTrace +0 StackAddrToStr
>> stack will be calculated soon



ansgar posted 10 months ago
That will be hard to fix, as the crash is in libmysql.dll, not in heidisql.exe. I have no clue why that's happening. Perhaps you should try a newer libmysql from mysql.com?
j.w.jones posted 10 months ago
Many thanks for that it works like a charm now. happy

Could you put the latest mysql lib in your distro from now on?

ansgar posted 10 months ago
oh that worked? Did not expect that... Which lib version is it now exactly?
j.w.jones posted 10 months ago
Nor did I if I'm honest. I have performed the query a number of times in case it was a fluke. It has crashed on me once in 10 times whereas before it was every time. Each time I tried I restarted HeidiSQL and loaded the query.

I downloaded mysql-connector-c-6.1.3-win32.zip from http://dev.mysql.com/downloads/connector/c/ and copied the libmysql.dll. I renamed the original one to .dll_old in case it didn't work but it did.

pizza111 posted 10 months ago
Ansgar and jones can recompile libmysql.dll by VC++.

Please login to leave a reply, or register at first.