distal-attribute
distal-attribute
distal-attribute
distal-attribute

Access denied for user user@127.0.0.1 when hostname = localhost

User, date Message
Written by pricejn2
4 months ago
Category: Creating a connection
3 posts since Tue, 18 Mar 14
I'm finding it impossible to connect using user@localhost. It seems to revert to user@127.0.0.1 for the actual connection.

Is there any way to force user@localhost rather than user@127.0.0.1?
Written by pricejn2
4 months ago
3 posts since Tue, 18 Mar 14
FYI, I'm running HeidiSQL on a Windows 7 machine.
Written by TTSneko
4 months ago
41 posts since Thu, 19 Jul 12
You should check the settings of your server package ... "localhost" is an alias for the IP address 127.0.0.1, however it has to be supported (and set up) via the corresponding server package.

Neither MySQL/HeidiSQL are responsible for this.
Written by pricejn2
4 months ago
3 posts since Tue, 18 Mar 14
Got it. Thanks!
 

Please login to leave a reply, or register at first.