distal-attribute
distal-attribute
distal-attribute
distal-attribute

[BUG] wrong position of ';' in SQL of exported tables

User, date Message
Written by dragos
8 years ago
Category: General
3 posts since Tue, 23 Jan 07
First, let me thank you for the work on this program (and mysqlfront 2.5 which I've been using for a long time)!

Now, the bug.
When exporting some tables to SQL you get something like:


/*!40000 ALTER TABLE myTable DISABLE KEYS;*/


and it should be


/*!40000 ALTER TABLE myTable DISABLE KEYS */;



I only noticed it when MySQL complained while trying to import the data via the command line executable.
mysqldump uses the second format also (at least on my 4.1.x version).
Written by ansgar
8 years ago
5045 posts since Fri, 07 Apr 06
Fixed!

See http://svn.sourceforge.net/viewvc/heidisql/exportsql.pas?view=log
Written by dragos
8 years ago
3 posts since Tue, 23 Jan 07
Excelent!
Thank you!
Written by rosenfield
8 years ago
127 posts since Wed, 24 Jan 07
It's not we who are wrong, it's MySQL.
Written by ansgar
8 years ago
5045 posts since Fri, 07 Apr 06
Yeah, rosenfield just made the whole thing more server-independent by adding a new option "Standard ANSI SQL" to the dropdown "Target compatibility".

If you select this new entry, the semicolons will be placed within the comment - which is the more correct syntax, but not (yet) supported by the mysql-servers.

If you choose one of the MySQL-options here, the semicolons will be placed outside the comment - which is needed if you want to re-import the file into another mysql-server.
Written by eu2
8 years ago
1 posts since Thu, 25 Jan 07
Any idea when the new version will be available for download with this fix? :)
Written by ansgar
8 years ago
5045 posts since Fri, 07 Apr 06
haha, I waited for this question :)

Sorry, no release plan yet. But you are free to download the sources and compile it for your needs.
 

Please login to leave a reply, or register at first.