distal-attribute
distal-attribute
distal-attribute
distal-attribute

wine and localhost use

User, date Message
Written by tresloukadu
7 years ago
Category: General
1 posts since Wed, 12 Dec 07
hey guys....

heide is working fine on my slack 12 .... The only problem that Im facing is that heide dosent connect in my local mySql .... a localhost connection dosent work at all.... I dont know why....

anywho i think that the problem is on wine not on heide itself .....

is anybody here who faced the same problem (wine doesnt access local mysql server) ?

tanks for any help!!!wink


ya later!!!
Written by xweber
7 years ago
5 posts since Wed, 12 Dec 07
no i dont have mysql's over network, but at least i can confirm the "localhost" problem for my linux/wine combination

Alex
Written by ansgar
7 years ago
5045 posts since Fri, 07 Apr 06
Perhaps try 127.0.0.1 ? Maybe the name "localhost" is not passed through the wine-system.
Written by xweber
7 years ago
5 posts since Wed, 12 Dec 07
localhost is just the name of the connection. The host field is filled with 127.0.0.1

Alex
Written by ansgar
7 years ago
5045 posts since Fri, 07 Apr 06
And 127.0.0.1 is not reachable with Wine + HeidiSQL ? What does

ping 127.0.0.1


say?
Written by xweber
7 years ago
5 posts since Wed, 12 Dec 07
... that its working fine:


ping 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.080 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.080 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.081 ms



however ping would say nothing in that situation (e.g. my firewall may block not ping, but anything to port 3306 - actually it doesn't). Other mysql tools have no problem to connect.

It may be a wine issue or something that changed whil 3.1 /3.2 of heidisql was developed. It's hard to track down. The main window after the "connect" dialog just does not appear. nothing in taskbar visible from wine/heidisql. If you hit Ctrl-C a small (wine/heidsql) popup shows up saying that Ctrl-C was hit.

Alex
Written by ansgar
7 years ago
5045 posts since Fri, 07 Apr 06

xweber wrote: The main window after the "connect" dialog just does not appear.



Ah... no error message from the server saying "Can't connect to bla" ?
Written by xweber
7 years ago
5 posts since Wed, 12 Dec 07
correct. There is no main window.

I just compared it to "native" windows. Even for the connection dialog the "greyed out" main windows in the background is just not there. So that may be the problem. It's just not visible.

Alex
Written by xweber
7 years ago
5 posts since Wed, 12 Dec 07
found a solution.

In registry the main window position went completely out of sight (value -54000). Dont know why that happen.

So clearing registry (with reinstall) gave me the main window back and now its working again.

Alex
Written by ansgar
7 years ago
5045 posts since Fri, 07 Apr 06
Great! Thanks for keeping this post up to date, so others will probably benefit from your solution.
Written by jamsession
6 years ago
120 posts since Sat, 22 Dec 07
On my Linux (fedora 9) computer, I installed wine before installing heidisql.exe.

I did this, because the heidisql, on my xp, was not connecting to the database, on my Linux server. (I suspected that Fedora 9's mysql had a bug.)

On the surface, everything seemed to work fine, except, after a while, I noticed that heidi was taking a very-long time uploading data to my database.

After more than 5 hours, I stopped the process and started looking for a faster way.

I theorize that, since the server/database is located on the same Linux computer, as my Heidi, and Heidisql.exe is a windows program, then translations, from windows format to Linux format, might be slowing things down.

Perhaps jHeidisql will work.

I would hate to have to upload my tables individually!

- j
Written by jamsession
6 years ago
120 posts since Sat, 22 Dec 07
Hey!

It worked!

Up to now, I had incorrectly-configured HeidiSQL and that's why I was encountering much grief.

However, when I finally got the configuation right, HeidiSQL was surprisingly-fast.

Briefly, I was moving a large database, from one Linux server to another.

So, I had to, first, download, the database and then upload it.

This time, however, I assumed that both servers were up-to-date and that was all that mattered (despite one being Redhat and the other being Fedora).

So, under Export>Destination (tab)>Target Compatability, I selected: "Same as source server (MySQL 5.0.5..."

...And that seemed to make all the difference!

The entire upload was over in about 2 minutes.

So, now, I am a very-relieved happy-camper! happy

- j
Written by rosenfield
6 years ago
127 posts since Wed, 24 Jan 07
Interesting finding. I wonder what SQL dialect you had it set to before?
Written by jamsession
6 years ago
120 posts since Sat, 22 Dec 07
Standard ANSI SQL

- j
Written by rosenfield
6 years ago
127 posts since Wed, 24 Jan 07
Ok. Could be HeidiSQL that causes it, but could just as well be the server's SQL parser.

Would be interesting to monitor CPU and IO and see which process it is that spikes. Or move mysqld to another machine and see which machine is maxed out while the transfer is ongoing.
 

Please login to leave a reply, or register at first.