distal-attribute
distal-attribute
distal-attribute
distal-attribute

SSH tunnel - using 127.0.0.1 instead of localhost

User, date Message
Written by bitkidoku
4 years ago
Category: Creating a connection
2 posts since Wed, 14 Jul 10
I started using HeidiSQL recently and I absolutely love it.

When I manually define SSH tunnel using 127.0.0.1 I can connect to the remote Mysql server without problems. But as I understand from the error message* when I try to use HeidiSQL's built in support for SSH tunneling, HeidiSQL makes the tunneling using 'localhost'.

Is there a way to change this default behavior?

* Error message is: Can't connect to MySQL server on 'localhost'
Written by fusioned
4 years ago
11 posts since Tue, 16 Nov 10
I would like to 2nd this. I have hosting with a firm which requires users to connect to 127.0.0.1 rather than 'localhost' - and whilst this works fine via a Putty shell tunnel, HeidiSQL tries to connect to localhost regardless of the setting.

If no one responds to this, I will put up a bug report.
Written by ansgar
4 years ago
4940 posts since Fri, 07 Apr 06
You should specify the SSH host - perhaps you oversaw that input box?
Written by ansgar
4 years ago
4940 posts since Fri, 07 Apr 06
Eh, not the SSH host - I meant the hostname/ip on the settings tab which needs 127.0.0.1 . Then, set the SSH host to the external server name.
Written by fusioned
4 years ago
11 posts since Tue, 16 Nov 10
Yes this is exactly how I have it - SSH host = server, settings tab hostname/IP to 127.0.0.1
Written by Rapid-eraser
4 years ago
34 posts since Wed, 23 Jun 10
did you try this :P
http://www.heidisql.com/forum.php?t=6765#p6765
Written by fusioned
4 years ago
11 posts since Tue, 16 Nov 10
Oddly enough, that works.

I already have a number of putty profiles setup for use with tortoiseSVN - and these work with HeidiSQL via plink without an issue. No need to input the username / password / key file here.
 

Please login to leave a reply, or register at first.