distal-attribute
distal-attribute
distal-attribute
distal-attribute

Works on XP, not on Vista

User, date Message
Written by simon_uk
4 years ago
Category: Creating a connection
8 posts since Sat, 11 Sep 10
Hi

I have a laptop running XP and a PC running Vista Home Premium SP2. Both are on the same network, connecting to the net through the same router.

I have entered exactly the same connection details into HeidiSQL on both computers. The XP one connects fine, but the Vista one says "SQL Error (2003): Can't connect to MySQL server on 'localhost' (10061)".

Do you have any idea why this might be?

Many thanks
Simon
Written by kalvaro
4 years ago
564 posts since Thu, 29 Nov 07
localhost is a synonym for this computer. Your description implies that you have installed MySQL Server in both computers and you have created the same user with the same password in both servers. Is that the case?
Written by simon_uk
4 years ago
8 posts since Sat, 11 Sep 10
No, I'm connecting to a remote Unix server via SSH tunnel.

In fact, I've now tried connecting to two different remote servers, and get the same problem with both - I can connect from the XP machine, but not from the Vista one.
Written by ansgar
4 years ago
4800 posts since Fri, 07 Apr 06
Obviously there is something different on both machines. Looks like this is not a privilege issue, but some problem between the Vista pc and the server. Probably the router allows only connecting from the XP computers IP address?
Written by simon_uk
4 years ago
8 posts since Sat, 11 Sep 10
The Vista machine can connect successully to both servers via Putty & WinSCP, but not from HeidiSQL.

It's a mystery...!

The Vista machine is my main work computer, so I'd love to solve this. Are there any other things connected with HeidiSQL I can look into - registry, DLLs, settings, etc.?

Written by ansgar
4 years ago
4800 posts since Fri, 07 Apr 06
SSH and MySQL use different ports, so maybe port 3306 is blocked?

Do you have the right libmysql.dll in the place where heidisql.exe is located? Have heard from various users which placed their .exe into some random temp folder.
Written by simon_uk
4 years ago
8 posts since Sat, 11 Sep 10
I installed HeidiSQL to C:/Program Files (x86)/HeidiSQL, the heidisql.exe file is in there, as is libmysql.dll (and also plink.exe).

Both computers connect to the internet via the same router, so I don't tihnk it can be a closed port problem.
Written by simon_uk
4 years ago
8 posts since Sat, 11 Sep 10
Interesting - I've just tried with a different SSH/SQL client and it connects fine, so it does seem to be a Heidi issue.

The other client is not open source though, so I'd much prefer to use Heidi if I can...
Written by ansgar
4 years ago
4800 posts since Fri, 07 Apr 06
I still have a gutt feeling you have set your HeidiSQL session on Vista to use SSH tunneling, as the error message tells me you're connecting to localhost:

Can't connect to MySQL server on 'localhost'


If not - just to make sure 4 eyes see more than 2 - could you post screenshots of both session settings?
Written by simon_uk
4 years ago
8 posts since Sat, 11 Sep 10
Yes, that's right, I am trying to connect via SSH tunnel (see 2nd message above).

Written by ansgar
4 years ago
4800 posts since Fri, 07 Apr 06
Is there an additional MySQL server installed on the Vista machine?
Written by simon_uk
4 years ago
8 posts since Sat, 11 Sep 10
I do use XAMPP on there sometimes, but it's not currently running
Written by simon_uk
4 years ago
8 posts since Sat, 11 Sep 10
Can I safely delete all entries in the Windows registry relating to HeidiSQL (using regedit)? e.g. hkey_current_user->software->heidisql

I'd like to try removing all traces of it then reinstall again.
Written by ansgar
4 years ago
4800 posts since Fri, 07 Apr 06
Yes, just remove or rename the HeidiSQL folder and restart HeidiSQL. No need to reinstall btw.
Written by wouter_van_nifterick
3 years ago
14 posts since Wed, 06 Oct 10
Try to telnet to your database server "manually" to verify that your network is set up properly.

From a console, type:

telnet localhost <PORT>

,

where <PORT> is the port that you're asking HeidiSQL to connect to.

* If that works (somehow I doubt it will), it's a HeidiSQL problem, and you should provide some more details.
* If it doesn't work, check your firewall settings, or doublecheck your tunnel setup.
 

Please login to leave a reply, or register at first.