distal-attribute
distal-attribute
distal-attribute
distal-attribute

SQL Error (1045): Access denied for user 'root'@'localhost' (using password: YES)

nickoo1234 posted 5 years ago in Creating a connection
When I try to connect to Heidi SQL for my World of Warcraft private server, I get this error message:

SQL Error (1045): Access denied for user 'root'@'localhost' (using password: YES)

Ive tried putting in NO password, I've tried ascent, AND I've tried root. Nothing works at all! Can somebody please help me fix this, this is very stressful.
Rapid-eraser posted 5 years ago
If you can connect local with phpmyadmin it seams that your credentials don't have remote access ( or mysql server its self doesn't accept remote access)

Try connecting through ssh tunneling where users don't have to be granted spacial remote access (read my posts for who to configuration plink+putty). If you don't want to use tunneling give remote access to your user reload privileges and try again.
kalvaro posted 5 years ago
I assume you have forgotten the password you chose when you installed MySQL. Try this: How to Reset the Root Password
kevin39 posted 2 days ago

You may across error #1045 Access Denied for user ‘root’@’localhost’ when yu try to access phpMyAdmin after complete installation of local host server. Main reason for this reason to take place is when the local host is not assigned with complete accessing authority or may be the password that is facilitated is incorrect. In order to solve this error you can try doing as follows: Step 1: Open MySQL console Step 2: Set Password= PASSWORD (Enter Your Password Here) Step 3: Open config.inc.php file situated in files of local server and edit it. Step 4: Access phpMyAdmin If above affirmed solution does not help you to get rid of error code 1045 then best option accessible is SQL Repair Tool that’s most reliable tool in order to fix error 1045 user access denied. It also recovers corrupted and damaged database files without backup and recovers stored procedures, views, indexes, tables, unique/primary keys, etc from damaged SQL database.

kevin39 posted 2 days ago

You may across error #1045 Access Denied for user ‘root’@’localhost’ when yu try to access phpMyAdmin after complete installation of local host server. Main reason for this reason to take place is when the local host is not assigned with complete accessing authority or may be the password that is facilitated is incorrect. In order to solve this error you can try doing as follows: Step 1: Open MySQL console Step 2: Set Password= PASSWORD (Enter Your Password Here) Step 3: Open config.inc.php file situated in files of local server and edit it. Step 4: Access phpMyAdmin If above affirmed solution does not help you to get rid of error code 1045 then best option accessible is SQL Repair Tool that’s most reliable tool in order to fix error 1045 user access denied. It also recovers corrupted and damaged database files without backup and recovers stored procedures, views, indexes, tables, unique/primary keys, etc from damaged SQL database.

http://sqlmdf.filerepairtool.net/blog/fix-mysql-error-1045-28000-access-denied-user

Please login to leave a reply, or register at first.