distal-attribute
distal-attribute
distal-attribute
distal-attribute

Heidi update glitches

User, date Message
Written by lemon_juice
3 years ago
Category: Installation
127 posts since Tue, 29 Jun 10
I've noticed a problem happening since about a month or so - every time I update Heidi to a new build through "check for updates" the installation stops on a window "closing session manager". Closing it doesn't help but when I close the main Heidi window then the process continues, Heidi is restarted and the new version installed.

This is happening to me on two computers: XP and Vista.
Written by ansgar
3 years ago
4940 posts since Fri, 07 Apr 06
Sounds exactly like issue #2217
Written by member
3 years ago
32 posts since Fri, 23 Apr 10
I asked how to close the session manager manually in the above link, now the link is giving a 500 error. Could you post the snswer here? Thanks
Written by member
3 years ago
32 posts since Fri, 23 Apr 10
I got around the problem by replacing the exe with the one from the download page. I had downloaded it and clicked on the download and it suggested I had to update from the program. I reread the instructions on the download page and saw I was to replace the exe, could you change the error message so it suggests to replace the exe instead of installing via the program. I should have read the instructions, but usually (in most cases) clicking the exe starts the install, when it says to use the program it is confusing (at least it was to me).

Issues and the link above are still rendering the following:

500. That’s an error.
The server encountered an error and could not complete your request.
If the problem persists, please report your problem and mention this error message and the query that caused it. That’s all we know.
Written by ansgar
3 years ago
4940 posts since Fri, 07 Apr 06
Man, the 500 error is a temporary error from Google Code.

You just have to close the HeidiSQL main window when the updater seems to wait for some dialog to close.
Written by member
3 years ago
32 posts since Fri, 23 Apr 10
ok, I thought it might have been some sort of php glitch on the Heidi end.

Restarting Heidi would not allow the update to proceed. As mentioned, I got around the issue. Thanks for listening. As always, I love HeidiSQL!
Written by ansgar
3 years ago
4940 posts since Fri, 07 Apr 06
I have just committed some changes to the updater which should solve these problems. Should work now. Only I got a new false positive detection in my antivirus software avira. Well...
Written by lemon_juice
3 years ago
127 posts since Tue, 29 Jun 10
Thanks, it works now - today I had the first successful auto-update since a few months ago.

I can't say anything about false positive detections because I stay away from antivirus software :)
 

Please login to leave a reply, or register at first.