distal-attribute
distal-attribute
distal-attribute
distal-attribute

MSSQL with Windows Security

User, date Message
Written by csiqojerncjsa
3 years ago
Category: Creating a connection
12 posts since Sun, 10 Jul 11
Hi !

I love HeidiSQL ! Long time I was working with MySQL Workbench but 3 days ago I heard about HeidiSQL and I will no longer use any ohter smile

When connecting to a MSSQL Server with UserName & PWD it works, using SQL Server Authentification.

I at the moment have no idea how to connect to this 2005 MSSQL using integrated Windows Security ?

What do I have to do or is this feature currently not available.

Cheers

Robert
Written by ansgar
3 years ago
4793 posts since Fri, 07 Apr 06
Thanks a lot for feedback!

Windows authentication is not yet supported in Heidi. Not sure if I will be able to manage that. But I guess you can pass the same credentials as you do on a Windows log on.
Written by csiqojerncjsa
3 years ago
12 posts since Sun, 10 Jul 11
Hi Angsar !

I tried that - logging on with windows username and pwd - but that doesnt work. As I am a developer myself (but not delphi unhappy) I know that when connecting to a mssql server with windows authetication requires a parameter like [Integrated Security=SSPI].

Cheers

Robert
Written by ansgar
3 years ago
4793 posts since Fri, 07 Apr 06
Good hint - will check whether setting "Integrated Security=SSPI" works as it should.
Written by rmcii
3 years ago
1 posts since Tue, 16 Aug 11
I too am extremely interested in being able to use HeidiSQL to log into mssql using Windows Authentication / Integrated Security.
Written by ansgar
2 years ago
4793 posts since Fri, 07 Apr 06
Done in r3972 - feel free to testsmileWell, works here on a 2008 server.
Written by gilrim
9 months ago
1 posts since Fri, 05 Jul 13
I just tried this when running HeidiSql in Wine on a Mint install. basically I need to tell the server that I'm using windows/AD credentials, but provide them in the username/password field. (My linux install isn't member of the domain).

I tried domain\username, usename alone and username@domain.tld - neither let me login.
 

Please login to leave a reply, or register at first.