unable to create/manage tables or table properties

karvane posted 6 years ago in General
I'm using a 64bit win7 and all of a sudden heidi 6 and 7 versions dont let me create new tables and allow me to edit the table properties of older ones. I can click on the table and see what data it has, but if I try to peek into Options or indexes for instance nothing changes.

Also when creating a table I can define the structure, but the save button is constantly grayed out and when I hop into another table it asks if I'd like to safe the current table, I press yes and it says "sorry, cant save table '' (no name).

I've tried to google the issue, but so far I have not got far. tried to restart computer, reinstall different versions of heidi, nothing.

Any suggestions?
ansgar posted 6 years ago
Hm, never heard that before, very strange. Probably you have some third party tool active which watches and modifies running applications in some way?
richard posted 5 years ago

i have the problem since a couple of month, too.
I run WinXP 32 bit.

I don't know at which nightlybuild was the switch, but
i have a old Version works fine, but all 7.x don't work.

The Mobile works fine.

The Second Row of Tabs (Basic/Options/Indexes/Foreign Key/Create Code/Alter Code) is completely missing.

Old Versions and mobile Version runs fine on the same computer.

I can send you screenshots, if you want.

If i can have access to all nightlybuilds (compiled one) ,
i will make the work and try out, @ which Version the error occurs....

ansgar posted 5 years ago
Please watch out for a splitter line which you can drag with your mouse, where the missing tabs used to be. I guess you see the "Columns:.." list at the very top?
richard posted 5 years ago

have you change anything?

The second row of tabs are reappear since nightly build 4100....

ansgar posted 5 years ago
Yes, see /forum.php?t=10384#p10415
ansgar posted 5 years ago
Eh... /forum.php?t=10384
richard posted 5 years ago
Great (Gro├čartig)

It works for me ...


mmem700 posted 5 years ago
I'm having the same issue as the original user "Karvane".

When I define a new table, the "Save" button is never enabled. I can define all of the columns just fine, but I can never save it because the Save button is always greyed out no matter what I do.

I'm using Win 2000 SP4 w/HeidiSQL
mmem700 posted 5 years ago
I figured out the solution. There are 2 necessary steps:

1. The top part of the tab was hidden on the "Table" tab, but by hovering near the top until the drag icon appeared, I was able to drag down and reveal the NAME and COMMENT fields.

2. The COMMENT field must be filled in for the "Save" button to become enabled. (and of course, the NAME field must be filled in as well, but this is expected).

karvane posted 5 years ago
Thanks for troubleshooting, now got it working for me as well.

Hope the devs can fix this little GUI bug.

I added a before/after screenshot as well

mmem700 posted 5 years ago
Very good. Thanks.

Please login to leave a reply, or register at first.