distal-attribute
distal-attribute
distal-attribute
distal-attribute

SSH tunnel fails if bind address is not 127.0.0.1

jtnewlands posted 5 years ago in Creating a connection
I'm curious why something won't work. I have several servers that have to communicate with each other, so their mysql bind address and their identity in /etc/hosts is their IP. I can ssh to them via putty or plink and then login to mysql as my localhost-only username and password, but when I try to set up a Heidi SQL connection via plink/SSH tunnel I get a 1045 access denied. The standard TCP connection using a user allowed from % works fine. I'd prefer to go through an SSH tunnel.

Is there something about having mysql listen at it's IP address that precludes a SSH tunnel also working at 127.0.0.1?

Thanks!
endo64 posted 10 months ago

I have the same problem with the latest version (9.4.0) and I think this happens because of your local MySQL is running and somehow HeidiSQL connects to your local instance whatever your ssh settings are. Even changing your local MySQL port doens't solve the problem, only solution is to stop local instance, then it works.

Please login to leave a reply, or register at first.