having trouble connecting to godaddy MySql database

spaceballone posted 4 years ago in General
Hi, I have a MySql database on godaddy and can't get HeidiSql 8 to connect. I'm using the ip address, username and password that show up on my PHPMyAdmin, so for example my admin page shows:

Server: via TCP/IP
User: mylogin@

I enter the same things in HeidiSQL (i've tried user with and without the "@") and get the following error message:

SQL Error (2003) in statement #0: Can't connect to MySQL server on '' (10060)

I've tried putting my credentials in the session manager and also prompting either way - no difference.

Also, I've checked and the port in HeidiSQL matches the port in my SQL System variables.
ansgar posted 4 years ago
See here
spaceballone posted 4 years ago
I found that thread before I posted mine. My 'skip networking' system variable is off, but the 'hostname' system variable does not have a % anywhere in it. Here's what it sort of looks like:


Where do I add the % sign? Beginning, end, or somewhere in the middle?

Also, how do I add it? I don't see an obvious way to edit the hostname in phpMyAdmin and I'm certainly not an expert in it..
jfalch posted 4 years ago
"Where do I add..." - you donĀ“t.

The hostname, ie the name of the host that the mysql server is running on, is not supposed to have a % anywhere. furthermore, you can not change it with such a hoster.

% is only used in the "mysql" databasesĀ“ "host" permission table, in the "hostname" field (NOT identical or related to the system variable), as a wildcard, matching several or many real host names.

however, this is pretty secondary; the most important information is contained in the third post (@kalvaro) of the thread mentioned by ansgar above: "Most hosting services prevent outside access to their databases by default. Some prevent it in all cases. In GoDaddy it depends on whether you are a pay customer" - well, are you a GoDaddy pay customer ? if so, i suggest you ask their support on how to access your databases using heidisql.
spaceballone posted 4 years ago
Ok, sorry I misunderstood the part about the % in that post.

I am a paying customer, so that's not an issue. From a little more time with google, it looks like I have to enable direct access and this can only be done when a database is newly set up. I don't remember if I did this or not when I set the database up.

I think I can re-create my DB again and enable it, but I've found some warnings about security if this is selected. How unsecure would I be? What's the worst case that would happen? I'm basically just using the DB to support comments/questions on a non wordpress website that I have so it's not like it's anything terribly important.
jfalch posted 4 years ago
you can dump out the current db contents with phpmyadmin to an .sql file, drop and re-create the database (with direct access), then reload the contents using heidisql. (nb: "@host" is nearly never part of a username)

then, for such a low-profile content, IMHO security implications are negligible. UNLESS you use the same access data (user/pass) on other, higher-impact systems (google, facebook accounts)...
spaceballone posted 4 years ago
Ok, great. I will give it a try. Thanks for the help!
tonygeorge87@gmail.com posted 4 years ago
simplw way to create database in godaddy http://hints.steptoinstall.com/add-create-mysql-database-user-godaddy-step-by-step-beginners.html
tonygeorge87@gmail.com posted 4 years ago

simple way to create database in godaddy http://hints.steptoinstall.com/add-create-mysql-database-user-godaddy-step-by-step-beginners.html[/quote]

Please login to leave a reply, or register at first.