Error Report: "Format '%s' invalid or incompatible with argument"

theocritus posted 4 years ago in General
I install MariaDB today, but when I tried to open HeidiSQL,
setting password and connect to localhost,
I got following error message.

date/time : 2013-07-04, 18:20:45, 705ms
operating system : Windows 7 x64 Service Pack 1 build 7601
system language : Chinese (Traditional)
processors : 8x Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz
physical memory : 8604/16343 MB (free/total)
free disk space : (C:) 53.70 GB
display mode : 1920x1080, 32 bit
allocated memory : 54.75 MB
executable : heidisql.exe
exec. date/time : 2013-05-19 07:12
version :
compiled with : Delphi XE
madExcept version : 3.0m beta 1
callstack crc : $8f80b6a6, $319be031, $319be031
exception number : 1
exception class : EConvertError
exception message : Format '%s' invalid or incompatible with argument.

main thread ($d877c):
004737e5 heidisql.exe SysUtils ConvertErrorFmt
00475d16 heidisql.exe SysUtils FormatError
004763b1 heidisql.exe SysUtils WideFormatError
00476603 heidisql.exe SysUtils WideFormatBuf.@label
004764e9 heidisql.exe SysUtils WideFormatBuf
00476144 heidisql.exe SysUtils FormatBuf
004762d0 heidisql.exe SysUtils FmtStr
0047624a heidisql.exe SysUtils Format
0047622f heidisql.exe SysUtils Format
00684a21 heidisql.exe helpers 2684 +2 f_
00725c06 heidisql.exe dbconnection 2014 +14 TMySQLConnection.GetLastError
00720352 heidisql.exe dbconnection 1141 +104 TMySQLConnection.SetActive
007ec843 heidisql.exe Main 3108 +8 TMainForm.InitConnection
0078ab4e heidisql.exe connections 292 +5 Tconnform.btnOpenClick
004e9725 heidisql.exe Controls TControl.DblClick
004e98a0 heidisql.exe Controls TControl.WMLButtonDblClk
0061edaa heidisql.exe VirtualTrees TBaseVirtualTree.WMLButtonDblClk
0062b4ef heidisql.exe VirtualTrees TBaseVirtualTree.WndProc
004ed100 heidisql.exe Controls TWinControl.MainWndProc
004ab958 heidisql.exe Classes StdWndProc
76e77885 USER32.dll DispatchMessageW
00575ffb heidisql.exe Forms TApplication.ProcessMessage
0057603e heidisql.exe Forms TApplication.HandleMessage
0057199d heidisql.exe Forms TCustomForm.ShowModal
007e63d5 heidisql.exe Main 1737 +94 TMainForm.AfterFormCreate
00819bd6 heidisql.exe heidisql 73 +21 initialization
776433a8 KERNEL32.dll BaseThreadInitThunk

I've found a post (http://www.heidisql.com/forum.php?t=12007)
talked about the format error might be chinese translation problem?

And I've tried the newest r4452, still has "Format '%s' invalid or incompatible with argument."

Thank you for reading this.
ansgar posted 4 years ago
Yes, indeed, an error in the chinese (taiwan) translation. Sigh... Just fixed that on Transifex. Please wait for the next commit to get the fix.

Please login to leave a reply, or register at first.