Crtl-C / Crtl-V not working after some time

R03l posted 4 years ago in General
When i use heidiSql (and previous versions back to 8.x) is notice that after some time i can't copy/paste queries anymore.
Even when i use the right-mouse actions i can only cut the queries or part of it. There is no way to paste the selected text anywhere, not in Heidi self or any other Windows program.

Running Windows 7 professional 64 bit
ansgar posted 4 years ago
This only applies to the query editor, right? Probably MS Office related?

I guess so, as I attempted to fix seemingly sporadic access violations in SynEdit in r4123. See also the report in issue #2076.
R03l posted 4 years ago
Sorry, but there are no exception messages anywhere to be found.

i have very lengthy queries that i test in Heidi and then paste to my program, and it's pretty annoying when that fails ;-(

I deinstalled heidi now an d will reinstall it completely and hope that makes a difference.
R03l posted 4 years ago
well reinstalling HeidiSQL made it all worse. now it fails right from the start.
R03l posted 4 years ago
OK, after sniffing around on the internet it seems the problem is not HeidiSQL related.
I tried deinstalling 8.1 and reinstalling 7.1, but even in this version i know had the problem.

I almost freeked out, but there is a solution.
Here the article
And here the solution program.
if you run this program then almost immediately the CTRL-V/CTRL-C works again. no need for restart of HeidiSQL
ansgar posted 4 years ago
Is there some relevant code in that forum thread? Can't find it in the myriad of posts there. The solution program is just an .exe from which we cannot learn anything.
jfalch posted 4 years ago
appears to be a general windows 7+ system problem, completely unrelated to heidisql. a summary of the different causes and possible solutions cited in the technet forum posts is here; i found it down at the bottom while reading the posts.
jfalch posted 4 years ago
NB: the GetOpenClipboardWindow program now appears to live here; it simply checks wether " some application [is] having a lock over the Windows
Clipboard"; probably using the GetOpenClipboardWindow windows API function.
rpm posted 4 years ago

I'm experiencing this same issue.

The program you mentioned GetOpenClipboardWindow, just says "Succewssfully opened and closed the clipboard. Does not appear to be any problems". So no help there.

I am able to copy and paste text out of the query editor in HeidiSQL, but not paste it into or between query tabs.

I've followed the advice at: http://www.tomshardware.co.uk/faq/id-1749049/fix-copy-paste-problems-microsoft-office.html also with no luck.

Any advice greatly appreciated. Not having the ability to paste long sql queries into the program is a nightmare!
rpm posted 4 years ago
I stumbled on the solution for me looking at Bigbear1700's answer in this thread: http://social.technet.microsoft.com/Forums/windows/en-US/5bbc11e8-ca2d-41ac-b640-d66ce971f58f/copy-paste-clipboard-issues-not-working?forum=w7itprogeneral.

"I also was having an issue trying to copy and paste a URL from my web browser to a dialog box within two different database programs and never had that issue before. I have Webroot SecureAnywhere installed on my computer and while reading your post it came to me to try disabling Webroot and try pasting, It worked.
May need to go into any anti virus programs and the like and check your configuration setup and allow copy & paste. I've been having this issue for several days, just wish I knew it was a simple fix sooner. Hope this helps or opens your eyes to a fix. Please let me know one way or the other if this helped you."

Disabling Webroot SecureAnywhere worked for me.

I hope this helps someone in the future with this frustrating issue.

Please login to leave a reply, or register at first.