Paste doesn't work in HeidiSQL

Danya posted 4 years ago in General
Hi there,

I have a problem that I can't paste data into table fields. I'm also unable to paste clipboard data to the new account popup, like when adding a new server, I can't paste server address, username or password.
Neither mouse-button or Ctrl+v work, field keeps being empty.

Copying data does work though. When I copy data from one table field into a notepad file, works fine. Pasting into an other field though leaves the field empty.

Anyone any idea how to solve this?

Many thanks!happy
BubikolRamios posted 4 years ago
I think there is a general windows prob with that.
In general at time that that happens close some other programs ant it might start to work.
Danya posted 4 years ago
Nope, even with all other programs closed, it still doesn't work.
Also, haven't got that issue with any other program, neither with MySQL Front.
BubikolRamios posted 4 years ago
Yesterday I had a prob trying to copy a value from hsql table field to net beans. Copy/paste did not work in any way, coz it has been pasting something that was on clipboard from before, stored there from net beans.

For no apparent reason it started working 5 minutes later.
I think it is a win problem.

Similar expirience with irfanview where occassionaly keyboard copy/paste does not work, doh menu thing does allways work.
Danya posted 4 years ago
Hm, copying works fine, pasting doesn't. Period.
As said, I ain't experiencing any other copy/paste problems in other programs.
Although it could indeed be a Win problem (I run XP Pro EN), I rather think it has somewhat todo with how HeidiSQL handles pasting.

Hopefully someone can help me out on this, cause it's quite annoying.
Danya posted 4 years ago

Turned out to be Webroot SecureAnywhere!
By unchecking a setting called 'silently and automatically block untrusted access to user data' the problem is solved!happy

Please login to leave a reply, or register at first.