Connection fail via SSH Tunnel

myc0058 posted 3 years ago in General
I want to connect remote Mysql server via SSH Tunnel.

local -> ssh server -> mysql server

but heidisql doesnt try to connect to mysql server

try to connect ssh server local.

plz help me.

best regards
ansgar posted 3 years ago
If it connects to localhost then check your SSH tunnel settings. You could also update to the latest build as I have rewritten the SSH tunnel recently, and you now get messages from the plink command line window as message dialogs. Perhaps when the server provides a new or changed key, then Heidi pops up with a question dialog which you need to confirm first.
myc0058 posted 3 years ago
I try to command line

D:\Data\util>plink -L 3307:DB_IP:3306 -P 22 -pw password moh_user@SSH_IP

and access localhost 3307 port number with HeidiSQL.

it works.

and heidiSQL's SSH Tunnel works also.

Did i have to use command line first time?

anyway thx
sme posted 3 years ago
You need the server key in your registry. This is done when you first connect to the server.

As ansgar said there should be already a fix to provide a dialog when needed.
apaffefettu posted 3 years ago
However, if I use the same credentials over SSH via the follow command line:

mysql -u social_shop_prod -h us-east-1.amazonaws.com -p
I can connect successfully and get the MySQL interactive command prompt

Please login to leave a reply, or register at first.