Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

can't recognize go commands?

reubendevries's profile image reubendevries posted 8 years ago in Running SQL scripts Permalink
It seems like when I run batch of commands that HeidiSQL doesn't like my Go command in between, but when I manually try with MS SQL Management 2012 it works. Has anyone else come across this issue.
kalvaro's profile image kalvaro posted 8 years ago Permalink
GO is a command from the SQLCMD utility that's also understood by SQL Server Management Studio. While it isn't strictly SQL I think it'd be a sensible feature request for HeidiSQL since it's very common in SQL Server scripts so I've opened a ticket in case the developer(s) can spare some time:

http://code.google.com/p/heidisql/issues/detail?id=3600

Feel free to comment into the ticket. I've never used GO with the optional parameter (in fact, I've only used GO so my scripts don't crash in SQLCMD) but it appears to be a batch separator that optionally allows to repeat the execution of last batch. A clear explanation in plain English would be a nice addition.
jfalch's profile image jfalch posted 8 years ago Permalink
go commands are not a part of sql, and thus not handled by heidisql ; they are only recognized by ms clients (management studio, sqlcmd), as a sort of processing instruction (take everything i have input so far and process it now).
kalvaro's profile image kalvaro posted 8 years ago Permalink
I still have mixed opinions about how HeidiSQL should deal with it. It's probably crazy to reimplement all the SQLCMD command set but "GO" is fairly common (basically because SQLCMD will not run complex SQL statements without it). Ignoring it can be simple but might lead to wrong expectations.
jimtut's profile image jimtut posted 6 years ago Permalink

Just came across this because I ran into the same thing. Would be nice to get this supported in HeidiSQL!

BTW, the link to the submitted ticket has changed. I'm not allowed to post links, so just add HTTPS:// to the beginning of this: sourceforge.net/p/heidisql/tickets/3600/

kalvaro's profile image kalvaro posted 5 years ago Permalink

SourceForce issue can still be found at https://sourceforge.net/p/heidisql/tickets/3600/ but I've opened a new ticket at current system:

https://github.com/HeidiSQL/HeidiSQL/issues/85

Feel free to provide feedback there.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.