HeidiSQL 9.1 released

ansgar posted 4 years ago in Anouncements
This is a maintenance release, which basically reintroduces support for legacy password encryption (pre-4.1 hash format).

Get it from the download page.



orion91 posted 4 years ago
After update to this version i see the button 'UPDATE AVAILABLE' on tool bar but: "Check for update beta version..." checkbox not checked in Preferences
yorro posted 4 years ago
Thanks for the quick fix.
dragonfire posted 4 years ago
Thanks man for all your work. I use your program everyday.
kilvroch posted 4 years ago
I've just upgraded to 9.1 (19.1.0.4867 64 bit) from 8.something.... and can no longer connect to my remote databases! The program simply hangs with "not responding" Is there something else I must do? I am running Windows 8.1
kilvroch posted 4 years ago
solved: I uninstalled, rebooted my machine, because HeidiSql was still showing active in Task Manager and I could not kill it there, re-installed and now everything is working fine
Guentiganz posted 4 years ago
The collation_connection is foced to utf8mb4_general_ci.
This leads to an replication error, when there is an older My-SQL Version
Guentiganz posted 4 years ago
a quick and dirty solution is to
set session collation_connection = latin1_swedish_ci

or whatever you need to use
ansgar posted 4 years ago

After update to this version i see the button 'UPDATE AVAILABLE' on tool bar but: "Check for update beta version..." checkbox not checked in Preferences


Yes, important updates are displayed in the upper right corner. Only the update dialog does not pop up automatically.
roger2hk posted 4 years ago

a quick and dirty solution is to
set session collation_connection = latin1_swedish_ci

or whatever you need to use


Yes, all my Chinese words are corrupted now.
MySQL 4.0.23
set session collation_connection = latin1_swedish_ci;
/* SQL Error (1193): Unknown system variable 'collation_connection' */
ansgar posted 4 years ago
On MySQL 4.x, HeidiSQL should report a silent error in the log panel, saying something like
/* Unknown character set: 'utf8mb4' */

After that, you should either see "Charset: utf8" or "Charset: latin1". Not sure if MySQL 4 already had utf8 support. What does your log panel say on that 4.0.23 server?
jfalch posted 4 years ago
this here seems to indicate that the older versions (4.x, 3.23) already had utf8.
Guentiganz posted 4 years ago

a quick and dirty solution is to
set session collation_connection = latin1_swedish_ci

or whatever you need to use


Yes, all my Chinese words are corrupted now.
MySQL 4.0.23
set session collation_connection = latin1_swedish_ci;
/* SQL Error (1193): Unknown system variable 'collation_connection' */



indeed you have to use the correct collation, as latin1 doesnt support utf8 you have to find the proper encoding.
in your case you should try utf8_general_ci

Guentiganz posted 4 years ago
and im pretty shure, that you don't have to change anything here, as heidi automaticaly uses the right encoding.
unless you have a repli using a different mysql-version
that was my problem.

and keep in mind, that heidi changes the collation, every time it has to reconnect, e.g. as of lost connection or standby of your client

Please login to leave a reply, or register at first.