Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Heidi takes 100% for about 30 seconds on startup and shutdown

jjaammhh's profile image jjaammhh posted 6 years ago in General Permalink
It takes a lot to start and close, because it takes 100% CPU for at least 30 seconds.

This blocks auto-updates, because the running processes never ends before the updater tries to overwrite the .exe file.

I'm using 32 bits, and I manually update (download the exe file and overwrite it) about twice a week.

This started happening about 2 months ago. I've been using HeidiSQL for years, and I've been always extremely happy with its agility and speed.

I suspect of the SQL log. I've tried deleting the queries history within the application, but the problem still persists. I've noticed than even deleting queries history, sometimes it reappears. If I could know where is it stored (filesystem or registry path, I would like to delete it manually).

Thanks in advanced to anyone can help me.
ansgar's profile image ansgar posted 6 years ago Permalink
Query history is located in registry, under HKEY_CURRENT_USER\Software\HeidiSQL\Servers\[Different SessionNames]\QueryHistory\
You can also delete them by rightclick on the history items > "Clear query history".

But I guess that's not the cause here as Heidi takes cares for the size of the history items, ensuring they do not exceed 1M.

It could also be caused by file logging. Check in Tools > Preferences > Logging > "Write SQL log to file".
In the folder name right besides that checkbox, check if you have large files there, and probably delete them when HeidiSQL is not running.
jjaammhh's profile image jjaammhh posted 6 years ago Permalink
Thanks Ansgar!

I saw that I had the "Write SQL log to file" box unchecked, so I gave a try to manual deletion of the SQL history in the registry, and now my Heidi installation is lightning fast again!

Before deleting the SQL history for some of my sessions, I've checked that they had stored a lot of queries, and some of them very large.

Perhaps in some nightly build it failed on ensuring the maximum 1MB size, and maybe it was being driven mad at load and shutdown times.

Anyway, many many thanks for your extremely awesome program, and for your valuable help.





Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.