Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

tables, views, procedures not longer expanding in tree view

rob-inoz's profile image rob-inoz posted 5 years ago in General Permalink
Since a few days,

when i try to expand eg. tables (or views or procedures, etc) in the tree in the left pan,
they do not longer expand, but show up in the right pane only.

so i see the + sign in front of tables(23)
but when i click on the +, it changes to -
but no tables or shown under it (they dont expand)
They only show up on the right.....

How can i fix this ?

Thanks
Rob
ansgar's profile image ansgar posted 5 years ago Permalink
You probably have a table filter on the top of the tree? Just clear that filter and they should appear again.
rob-inoz's profile image rob-inoz posted 5 years ago Permalink
I found itsmileYou pointed me in the right direction,

The option "show only favourite tree items" was active,
funny never noticed this option before....
pfew took me 3 weeks before i noticed this now surprised

thanks again for your help !

Rob
Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
TheOneDaveYoung's profile image TheOneDaveYoung posted 4 years ago Permalink

I know this is old but revisiting because the same thing is happening to me. HeidiSQL v9.3.0.5116 on Windows 10. Prior to this update, tables / views / functions / etc appeared on the left under the DB name. I could roll them up by clicking the DB name (the arrow points to the right and nothing is listed under the DB name). Clicking on the DB name now changes the arrow state but no tables / views / functions are listed. See the attached image grab.

You can see the tables are there on the right pane and you can also see there is no filter (DB or table) set.

Note the DB name and some tables obfuscated to protect the innocent. smile

Anyhoo, this isn't the biggest issue in the world but its a bit of a pain having to bounce back and forth to the DB tab to see the list of tables.

Thanks for the help!

1 attachment(s):
  • HeidiSQL-Table-Issue
TheOneDaveYoung's profile image TheOneDaveYoung posted 4 years ago Permalink

Figured this out. I had the "Show Only Favorites" icon (the yellow star) selected. Doh!

khalifaxrmili's profile image khalifaxrmili posted 3 weeks ago Permalink

Oh Maan, i had the favorites enabled !

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.