Error While Accessing the Recordrs for SQL Server Database

davidjones posted 4 years ago in Running SQL scripts
I am getting an error while accessing the records from the SQL database:

"Unable to process index I_NAME of table O_NAME because filegroup F_NAME is invalid"

please help me!
laurascott posted 4 years ago
Reason of the above problem is one of the file group IDs saved in Meta data for indexes do not exist and the index cannot be checked.Check your hardware,Run the diagnostic and correct the problem if any.
davidjones posted 4 years ago
I have checked the hardware but it is working very well. Now what to do?
laurascott posted 4 years ago
Hi David,

If you have the clean and updated backup then you can restore your database from it.If you do not have any clean backup then, run DBCC CHECKDB command without repair clause to check the extent of corruption. Again run the same command with the proper repair option to isolate the problem.

Good Luck!
davidjones posted 4 years ago
I do not have backup so I tried the second option. It's not working.unhappy

Please suggest me any tool free or paid so because my data is very important.
laurascott posted 4 years ago
I do not have much idea about free tools but I can suggest on paid tool to repair your important data.you can try stellar sql database repair tool.here is the link:
http://www.stellarinfo.com/sql-recovery.htm

Note: Please try the demo version of any data recovery tool before complete registration.‚Äč
davidjones posted 4 years ago
Yipeee it worked...

Many many thanks to you laura and you made my day. :)
TTSneko posted 3 years ago

I love how people suddenly panic when they lose "oh so important data" but at the same time admit that they do not have a backup ...

Please login to leave a reply, or register at first.