Blurry fonts on Windows 10

kalvaro posted 4 years ago in General
If you've upgraded to Windows 10 and text in most applications looks like crap (including HeidiSQL) there's at least a workaround. Right click on the shortcut icon, select "Properties" and find the "Compatibility" tab. Enable the "Disable display scaling on high DPI settings" checkbox and save changes. Sadly, it needs to be done manually for each application.

Feel free to share better solutions—I'm still trying to figure out why latest Microsoft OS seems to be optimised for 72 dpi CRT displays.
kalvaro posted 4 years ago
Follow-up: in the end, I disabled system-wide support for high definition displays. Some system texts are smaller than I'd like but now my apps look fine again.

pampurio97 posted 3 years ago
I can't call this a solution. With that option enabled, the text is not blurry anymore, but there are other scaling issues in the application.



Seriously, this needs to be fixed because it's a really bad experience both with and w/o that option.
ansgar posted 3 years ago
Is it just the grey text hint on the filter input boxes? If so, this is a small cosmetic thing, or?
pampurio97 posted 3 years ago
It's not just that. Icons are really small too.
But the point is that the application should work well normally without messing with Windows options. I don't know which platform is HeidiSQL built with (WPF, WinForms, etc.), but native high-DPI support can be enabled.
ansgar posted 3 years ago
There is no checkbox for "Enable high dpi support and magically fix all glitches this brings up" in Delphi. Instead, we have a TForm.Scaled=True/False property, which is broken for most form controls. So, I guess this needs much more work, especially for Win 8.1 with different DPI per monitor feature. Some useful hints can be found here: http://www.helpandmanual.com/downloads_delphi.html

Please login to leave a reply, or register at first.