Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Unable to connect to a remote server

doncell6's profile image doncell6 posted 4 years ago in Creating a connection Permalink
Running Heidisql version 9.3.0.4984 on a Windows 7 Pro pc fully patched. The name of the pc is z210. This pc is part of a Small Business Server 2008 domain. The MySQL database is on the server.

The problem: When I try to connect to the remote MySQL , I get the error:
“Access denied for user usradminr@z210 (using password:YES)”
Here are the log in parameters I am using in Heidisql:
- Network type: MySQL (tcp/ip)
- Hostname /ip: ml350 (this is the name of the server)
Port: 3306

I enter the correct password and username. I can successfully connect to the remote MySQL using Workbench from this pc so I know MySQL is working and will accept a remote login.

What must be done to enable Heidisql to connect to the remote MySQL ?
spacebar's profile image spacebar posted 4 years ago Permalink
See if adding a credential for the server you want to connect to on your Win7 pc using the Credential Manager found in the windows control panel.
Also check out this info:
http://dba.stackexchange.com/questions/66014/connect-to-sql-server-with-windows-authentication-in-a-different-domain
ansgar's profile image ansgar posted 4 years ago Permalink
Well, the message says it: Access denied. This means the server is accepting remote connections but rejects your user/password, or your pc name is not allowed with that user. As you said you tested Workbench from the same pc, then it can only be a wrong user/password combination.
Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 4 years ago Permalink
@spacebar: doncell6 mentioned a MySQL connection, not MSSQL.
doncell6's profile image doncell6 posted 4 years ago Permalink
Hello spacebar
Your credential idea worked well!! Thank you for your help.

Please login to leave a reply, or register at first.