Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Blurry text on 4k display

sumon's profile image sumon posted 4 years ago in General Permalink

Hello there, i really love to work with HeidiSQL.i recently move to a 4k screen (250% display scaling) and now heidisql UI is blurry.if i enable "Disable display scaling on High DPI settings" ui is meesed up.please look at the attachments for more details.

The laptop i'm using is dell XPS 15 9550. Win 10(64 bit)

2 attachment(s):
  • 1
  • 2
sumon's profile image sumon posted 4 years ago Permalink

from what i read from microsoft site,you need to use TrueType fonts instead of bitmapped font...is that correct?

ansgar's profile image ansgar posted 4 years ago Permalink

I don't know, but I'm quite sure that the font which HeidiSQL uses by default (Segeo UI) is a TrueType font.

Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
sumon's profile image sumon posted 4 years ago Permalink

so any plans to make it support in HiDPI displays? it really is very frustating to see a good software like this not supporting latest technologies. i'm so used to it,im not finding any better alternative to HeidiSQL.

ansgar's profile image ansgar posted 4 years ago Permalink

I don't even know whether that's an issue in HeidiSQL itself or a Windows issue. What can I do to support High DPI settings on newer Windows versions?

sumon's profile image sumon posted 4 years ago Permalink

its not an windows issue of course.From what i read,you have to make it DPI aware.did you see the picture on this thread? texts and icons are blurry.

sumon's profile image sumon posted 4 years ago Permalink

can you please take a look at the following link:

https://msdn.microsoft.com/en-us/library/windows/desktop/dn469266(v=vs.85).aspx

it explains everything about supporting HiDPI display and get rid of blurry fonts and icons.

Code modification/commit from ansgarbecker, 4 years ago, revision 5078
Attempt to fix high DPI awareness. See http://www.heidisql.com/forum.php?t=21287
ansgar's profile image ansgar posted 4 years ago Permalink

I found this article and added some code to HeidiSQL's manifest file. This changes displaying a scaled/blurry HeidiSQL on Win7 at least. Not the whole story of this issue I guess, but as I don't have Win10 here, you could be so nice and test the new HeidiSQL build and report back how it looks like on your end. Probably post a new screenshot.

sumon's profile image sumon posted 4 years ago Permalink

Thanks for your work.i've tried the latest nightly build,and seems like the UI is messed up.Its the same as running the old with "Disable display scaling " from compitability tab.

1 attachment(s):
  • messed
Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 4 years ago Permalink

Yes, but I think it was a step into the right direction. Now there are some controls to fix, eg the database and table filter input boxes, and the toolbar buttons with the icons being too small. Some other things in your screeny are just fixable by widening the database tree, or by making some columns wider.

sumon's profile image sumon posted 4 years ago Permalink

Yes.You have made the application DPI aware by declaring in mainfest file.But the internal code i think it not changed according.Thats why its out of order.

sumon's profile image sumon posted 4 years ago Permalink

Also can you tell me where does HeidiSQL saves current db settings? because i uninstalled and reinstalled heidisql,but the OLD connections were still there.

ansgar's profile image ansgar posted 4 years ago Permalink

The messed up controls are caused by Delphi's lack of support for high DPI settings, even for some 1st party controls, like the TButtonedEdit (the database + table filter). There are some quirks to work around that, but I couldn't find something for all of them yet.

sumon's profile image sumon posted 4 years ago Permalink

For your cconvenience,i took more screenshots and attahced them.Looks like text is all fine except 1 place where its overlapping one another.apart from that,the problem right now is 2: 1)Some filter boxes are small 2)Some columns are by default too small despite having space on the right.

3 attachment(s):
  • start
  • start2
  • start3
sumon's profile image sumon posted 4 years ago Permalink

The last screenshot is from my another computer with same display size but properly scaled.Notice the full database name.But on #2 ,you can see the database_name column is small despite having space.

3 attachment(s):
  • start3
  • start5
  • start6
sumon's profile image sumon posted 4 years ago Permalink

Look at the following link regarding incorrect layout:

https://msdn.microsoft.com/en-us/library/windows/desktop/dn469266(v=vs.85).aspx#incorrect_layout

ansgar's profile image ansgar posted 4 years ago Permalink

That help document is totally useless here. As said above, we need fixes for Delphi's 1st party controls which are not DPI-scalable. Especially for that TButtonedEdit control, but there are more.

nabla's profile image nabla posted 4 years ago Permalink

I've a Precision M3800 since 2014, it is my first HiDPI laptop. I've found any sort of buggy and messy UI in almost all software I use. Expecially Java based software have horrible rendering. Extra small unreadable texts, icon too small to be clickable, overlapping texts etc etc

The only software that really hasn't a buggy UI was HeidiSQL. A bit blurry, but fully usable.

Until today.

I updated to 9.0.3.5078 and I found a really unusable UI. icon too small to be clicable, overlapping texts and all other messed things I hated in other software.

I read here that there is a "Disable display scaling on High DPI settings" but I can't find it.

Can I ask you there to find is this option?

For me is really better a UI a bit out of focus than an unusable sharp UI like this.

Thanks

nabla's profile image nabla posted 4 years ago Permalink

("where to find", not "there to find", sorry)

ansgar's profile image ansgar posted 4 years ago Permalink

A bit blurry, but fully usable.

Yes, that was the case before r5078. But that blurriness is what sumon complained about, so I configured HeidiSQL's manifest/xml file so that it tells Windows: "I am DPI aware, please do not scale and make me blurry".

I'm very unsure whether I should revert that change or to keep it. If I keep it, I need quirks for the wrongly painted controls, like the database + table filter boxes, and some more. I could not find anything here, so it may be a better idea to revert the above mentioned change in the manifest file.

nabla's profile image nabla posted 4 years ago Permalink

After using this version a several hours I think it's almost usable.

3 problems:

1- Icons, expecially in the toolbar, are too small, it's hard to click on the correct one 2- "filter database" and "filter table" input box are the only 2 control that are problematic (You can't almost read what you are writing), 3- menu texts are overlapping

Only point 1 is really a problem. Point 2 and 3 are not a blocking problem if you use a bit of attention.

So I think that if you use a bit of workaround (such doubling icon size when HI-DPI detected) you can keep the new changes: hi res data grid are very good compared to the old blurred one that I see until today.

Thanks

sumon's profile image sumon posted 4 years ago Permalink

this one is definately better than blurry one.Can you fix 2 things only:

1)Table and database filter box. 2) Columns inside "data" tab are always too small.i have to manually enlarge almost every column on every table.

there 2 should be fixable i guess.when you detect Hi-Resolution,as nabla suggestted,you can increase the size or something?

1 attachment(s):
  • small
ansgar's profile image ansgar posted 4 years ago Permalink

1- Icons, expecially in the toolbar, are too small, it's hard to click on the correct one

Yes, agree - I can test if setting the width and height of the underlying images + the tool buttons themselves can fix that.

1)Table and database filter box.

That's the one which I couldn't find a fix for. Please read my replies, sumon .

Columns inside "data" tab are always too small.

Yes, that should be fixable without much hassle.

sumon's profile image sumon posted 4 years ago Permalink

well then.if you can fix those, it will be usable.we can live with small filter box for now.

btw,which delhpi do you use? because i went to delphi website ,seems like delphi 10 has good support for HiDPI including Tbutton and Tforms.

ansgar's profile image ansgar posted 4 years ago Permalink

I am using Delphi XE5 Professional, which I bought in 2010 for ~1000 EUR. Embarcadero makes a new release nearly each year, and I cannot keep track with them due to these prices.

motrik's profile image motrik posted 4 years ago Permalink

Lenovo Y50-70 15", Windows 10.0.10586 x64, display 4k (3840x2160 pixel), 250% display scaling HeidiSQL Revision 5078 (yours: 5078)

1 attachment(s):
  • heidisql_4k
sumon's profile image sumon posted 4 years ago Permalink

any update on this issue?

sumon's profile image sumon posted 4 years ago Permalink

you were supposed to push an update to fix few things as discussed.did you get time to fix those?

justrusty's profile image justrusty posted 4 years ago Permalink

No solutions yet. Still unusable on 4k screens.

ansgar's profile image ansgar posted 4 years ago Permalink

I have spent various hours of my free time on this issue. And believe me, support for high dpi settings in Delphi XE5 is horrible. I tried to enlargen the main toolbar and its buttons, with a result that the button width can be widened but the height is still wrong. And the icons cannot be resized for some reason I don't know - tried the double height/width with no luck.

Feel free to contribute some working solution here.

SQLer's profile image SQLer posted 4 years ago Permalink

I don't know if this has been officially fixed but maybe my experience can help some people. I have a lenovo laptop with Windows 10 Pro hooked up via a docking station to a 2560x1440 display. I use 125% scaling and did not experience any issue at first with HeidiSQL but then today for some odd reason the scaling was broken(maybe daily undocking reset something at some point).

I tried changing the scaling to all possible settings and signing in and out and restarting the program. Nothing worked until I right clicked the shortcut and enabled compatibility mode for windows 8 and checked the "Disable scaling on high DPI settings". I have tried this before with now effect but now for some reason it worked. Now 125% scaling works and it is scaled to 125% even though scaling now should be off - that's what the setting says it will do! So yeah there is some sort of bug in windows or something. Not having used Win 10 before all I can say is that the scaling in general is still broken. I have all the latest patches and A LOT of Windows own dialog boxes are not scaled properly. Running HeidiSQL 9.3.0.4984 64 bit btw.

jamesvl's profile image jamesvl posted 4 years ago Permalink

I'm on Windows 10, 4k display, and just updated to the 9.4 branches of HeidiSQL.

I had put off updating for a while since the old builds that had HiDPI working actually did work just fine for me. Unfortuantely, 9.4 took those changes away so all the app text was blurry.

What worked for me

Per SQLer above, I went into the app properties, Compatability tab, and checked "``` Disable display scaling on high DPI settings"



With my display set to 125%, all the text in the app is again crisp and things seem to be working.
eos's profile image eos posted 4 years ago Permalink

I have the same issue since the Windows 10 Anniversary update. The fonts heidiSQL users are all blurred on my Dell 30" 2560x1600 displays. Fonts in the file explorer for example are super sharp, as are those in

eos's profile image eos posted 4 years ago Permalink

I have the same issue since the Windows 10 Anniversary update. The fonts heidiSQL users are all blurred on my Dell 30" 2560x1600 displays. Fonts in the file explorer for example are super sharp, as are those in Intellij. I dont have a high DPI. I tried in both 100% and 125%.

justrusty's profile image justrusty posted 4 years ago Permalink

I'd rather have ever so slightly blurred fonts and icons than not be able to use the program at all.

What was the last version with the old display settings? As the current version is unusable on 4k display no matter what scaling and compatibility settings are used. Is it possible to download an older nightly without the messed up display?

I really like this program and would love to donate if this display issue can be fixed. Currently the whole thing is not even usable though.

jamesvl's profile image jamesvl posted 4 years ago Permalink

justrusty - I take it you tried the "Disable display scaling" option when running the app?

On the latest Windows 10 builds and latest HeidiSQL builds, that restored the text to being very crisp for me. (I still have some issues where some panes can't be resized, but the program is still very usable.)

eos's profile image eos posted 4 years ago Permalink

Hi Justrysty - where is the "Disable display scaling" option? I cant find anything like this in windows nor the app. For me, the fonts are blurry with a standard "normal" DPI monitor since windows 10 updates (Was find on windows 7 and 8)

justrusty - I take it you tried the "Disable display scaling" option when running the app?

On the latest Windows 10 builds and latest HeidiSQL builds, that restored the text to being very crisp for me. (I still have some issues where some panes can't be resized, but the program is still very usable.)

jamesvl's profile image jamesvl posted 4 years ago Permalink

eos - try this, and see if it helps:

  1. right-click on the app shortcut and windows, choose "Properties"
  2. click the "Compatibility" tab
  3. toward the bottom there should be the option you're looking for - place a check in "Disable display scaling..."
  4. click OK to save the changes, then launch HeidiSQL
justrusty's profile image justrusty posted 4 years ago Permalink

Yeah it does nothing for me. Windows 10 4k display at 250%. Display scaling turned off in properties but all the icons are still tiny unclickable and the line heights are wrong in the menus, fonts cut off unreadable etc. Before it was just slightly blurry icons but usable

ansgar's profile image ansgar posted 2 years ago Permalink

For those who did not yet notice: I fixed the biggest problems regarding high-dpi mode in the nightly builds. See the ticket for more information on that: https://github.com/HeidiSQL/HeidiSQL/issues/213 Or just try out by updating to the latest build.

nabla's profile image nabla posted 2 years ago Permalink

oh thanks, very impressive results! no more blurry texts! There are still some (very) small things to fix, but it's definitely a big step forward, thanks!

nabla's profile image nabla posted 2 years ago Permalink

I am sorry but HeidiSQL has become unusable. It's all quite right until I've tried to create a new table.

As soon as I press the menu button to create a new table, the main window height change and jumps to tens of thousands of pixels. If I try to resize the window, the software hangs. I see only "name" and a gigantic "comment" fields, that occupy the entire screen (impossible to insert fields in the table that you want to create, they are thousand of pixels below the avisibile area and there is no way to move/resize the main window whithout software hangs) Uninstalled and reinstalled a previous version, but somewhere the software has recorded the size of the windows: all windows are very big (no problem, they are resizable), but it is still impossible to create a new table because the main window still jumps to an height of tens of thousands of pixels. How do I uninstall and reset all settings?

ansgar's profile image ansgar posted 2 years ago Permalink

You can downgrade to the last release, or whatever build you prefer.

But before you do that, you should check whether you're really on the latest build, as the problem you're describing sounds like one I had some builds before.

jamesvl's profile image jamesvl posted 2 years ago Permalink

Just wanted to express my appreciation for all your HiDPI work - I'm using the latest build daily, and it's working quite well for me! (I know there's still a couple of minor, oustanding things on your list, of course).

Anyhow: thank you - I'm really liking it!

ansgar's profile image ansgar posted 2 years ago Permalink

Thanks for your appreciation!

I am currently searching for remaining issues with this. Apart from the routine editor I can't find any. Would be nice if you'd report them.

weyoun_9th@yahoo.de's profile image weyoun_9th@yahoo.de posted 4 months ago Permalink

The blurry text on 4K display really looks ugly.

I found out the problem does not exist in version HeidiSQL_10.2.0.5599.

You can find it under "Download" -> "Previous installers"

With HeidiSQL_10.3.0.5771_Setup the blurriness began.

@ansgar: Hope that helps to research this issue.

nabla's profile image nabla posted 4 months ago Permalink

Yes, years passes, but the problems of the graphic interface on Hi-DPI have never been really addressed. In the latest versions, input text fields are unusable, after few seconcs of writing, you lose control of where the cursor is. You have to write queries on a notepad and then copy/paste because it is impossible to edit them directly on HeidiSQL

weyoun_9th@yahoo.de's profile image weyoun_9th@yahoo.de posted 4 months ago Permalink

Means:

Version 11: I have to live with blurriness.

Version 10: I have to write queries outside HeidiSQL and copy/paste them.

Pain :-/

Is there no way to activate the "old" UI mode from HeidiSQL_10.2.0.5599 in newer versions?

ansgar's profile image ansgar posted 4 months ago Permalink

Yes, there is, see this comment.

Note that high DPI awareness introduced many new issues, so I decided to drop support for it. If you override this setting, you're left on your own when finding bugs with too large inputs or similar stuff.

nabla's profile image nabla posted 4 months ago Permalink

Not exactly:

  • uninstall HeidiSQL
  • manualli remove all entries in the Windows registry
  • remove all the files in the program directory
  • fresh install HeidiSQL
  1. Text blurred, but "less blurred" than a few years ago, quite usable

  2. "Query" field unusable: not updating correctly. The cursor disappears from time to time: you could write any query for the first time, but you cannot edit it, because if you click in the middle of the text already written, it is impossible to see the changes and the cursor often disappears (CTRL + F8 is required for force update). Switching to the "Windows" theme lighten (but does not solve) the problem

No forcing DPI, the only fault is "having a HiDPI display"

weyoun_9th@yahoo.de's profile image weyoun_9th@yahoo.de posted 1 month ago Permalink

I finally found out how to fix it:

As Ansgar mentioned you have to check your compatibilty settings:

Choose "APPLICATION" and every program will look fine in higher resolutions. No more blurriness.

1 attachment(s):
  • Anmerkung-2020-07-08-171613

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.