Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.

Keyboard interactive auth with Plink

jankal posted 3 years ago in Creating a connection

Hello @all,

I'm using HeidiSQL ver. 9.3.0.5093 and want to establish a connection to my remote server where I'm running mysql 5.7 bond to 127.0.0.1.

For this I usually use a SSH tunnel to connect to the server. But since I extended my authentication with a additional PAM passwort question after authentication with the key succeeded, HeidiSQL doesn't want to work anymore.

Everytime I'm opening a connection, HeidiSQL opens a window (screenshot attached) with no ability to input the password anywhere. When I then click okay, it immidiatly closes the connection saying "Can't connect to mysql server on 'localhost' (10061)".

I personally think, that this is a software caused issue cause HeidiSQL isn't parsing the aoutput from plink. So it doesn't detect if plink expects input now. Hopefully you can fix this issue with an appropriate patch.

Best regards,

Alexander Jank - http://alexanderjank.de

1 attachment(s):
  • plink_heidi
jankal posted 3 years ago

Hey @all,

I've now tried some things out: I disabled the addtional auth by adding a new PAM rule which allows the user to login without having to type teh password.

But now I'm getting another error (see attached screenshot). When I'm logging in using Putty it logs me in (image attached too - you need to know, that the user apparently is also sent over to PAM "Further authentication required" but then is logged in without typing a password).

Best regards,

Alexander Jank - http://alexanderjank.de

2 attachment(s):
  • lost_connection
  • putty

Please login to leave a reply, or register at first.