Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.

Heidi SQL and high dpi

dc's profile image dc posted 3 years ago in General

Is there a chance to make HeidiSQL behave properly on high dpi systems? Now it looks really bad. Screenshot is taken on resolution 3200x1800

Thanks in advance, dc

1 attachment(s):
  • heidiSQL-high-dpi01
HamptonNorth's profile image HamptonNorth posted 3 years ago

Exact same issue. Running 3840 x 2160 on main screen and 1920x1080 on extended second display. Both displays have v. small toolbar icons and screwed up Database/Table Filters input boxes. Auto scaling in use with main screen at 200% and second screen at 100%

ansgar's profile image ansgar posted 3 years ago

Yes, that's a known issue in HeidiSQL. Unfortunately, Delphi XE5's support for high dpi dialogs and forms is horrible. Apart from setting the dpiAware flag per manifest file, which I recently did to prevent Windows from upscaling and blurring, there is not much I can do. The icons cannot be scaled, many input fields do not respond as they should when trying to set their height, etc.



Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.
dc's profile image dc posted 3 years ago

I see. Maybe you could try to prepare manifest file for bitmap scaling like explained here: https://spaghettidba.com/2015/10/14/ssms-in-high-dpi-displays-how-to-stop-the-madness/?

kalvaro's profile image kalvaro posted 3 years ago

How bad was the upscaling blur to begin with? If Delphi lacks proper support for high DPI displays, perhaps it's better to just not pretend the app is dpiAware. Not to mention that good old FamFamFam Silk icons come in good old 16x16 px format.

As a personal note, I've been using monitors slighly over the minimum resolution since Windows 98 and I can tell you that programmers in general and GUI library creators in particular hate displays over 72dpi to the bones.

HamptonNorth's profile image HamptonNorth posted 3 years ago

I was perfectly happy with the scaling issues until last week. Unfortunately, cannot say which build caused issue. Great product regardless

ansgar's profile image ansgar posted 3 years ago

Well, there were others complaining about blurriness with bitmap scaling. But I also think that's better than the current situation.

ansgar's profile image ansgar posted 3 years ago

r5107 reverts that dpi-aware flag in HeidiSQL's manifest file.

HamptonNorth's profile image HamptonNorth posted 3 years ago

r5107 works fine for me. Thanks

dc's profile image dc posted 3 years ago

Hi, just gave it a try and it's much better than it was. At least now it's usable :)

To be honest it is blurry as you can see in screenshot which compares both versions (without any post processing). Fonts in menu are good enough, but maybe something could be done with most frustrating part: font in SQL windows and log?

Anyways, since it doesn't break anything for users with standard dpi I'd prefer to stay on this release. Thank you

1 attachment(s):
  • heidiSQL-high-dpi01-r5104_vs_r5107


Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.
BishopEmpire's profile image BishopEmpire posted 5 months ago

Running v10.1.0.5487 and still experiencing the upscaling with high dpi. What is the fix?

1 attachment(s):
  • Heidi_UpScale_HighDPI_v10-1-0-5487
ansgar's profile image ansgar posted 5 months ago

Your screen does not look like Heidi was upscaled. But there's quite some things to fix for me. Which DPI setting are you running there? Looks really high?

BishopEmpire's profile image BishopEmpire posted 5 months ago

Resolution: 1920 x 1080

ansgar's profile image ansgar posted 5 months ago

1920x1080 is a screen resolution, not a DPI setting. DPI settings can be expressed in percent, e.g. 100% or 150%. Or you have fixed values like 96 DPI (the default on Windows).

kalvaro's profile image kalvaro posted 5 months ago

The settings look like this on Windows 10:

Screenshot found on the internet

1920x1080 is not really a desktop size that requires a very high DPI setting. This tends to be an issue with e.g 4K monitors (3840 x 2160) that can have values like 200 or 300 dpi (depending on the actual monitor size).

BishopEmpire's profile image BishopEmpire posted 5 months ago

My settings are:

  • Change the size of text, apps, and other items: 100% (Recommended)
  • Resolution: 1920 x 1080 (Recommended)
  • Orientation: Landscape
ansgar's profile image ansgar posted 5 months ago

100% means you have default DPI setting. So the question is why your screenshot looks as if it reacted on a setting like 150% or so.

Please check if you have set a custom GUI font in HeidiSQL: Tools > Preferences > General. Set it to "Default" if so.

1 attachment(s):
  • gui-font-default
BishopEmpire's profile image BishopEmpire posted 5 months ago

GUI Font: <Default System Font> @ 8pt

ansgar's profile image ansgar posted 5 months ago

And HeidiSQL is still displayed with larger fonts? With 100% DPI and default GUI font? Sounds odd.

You could select the default "Windows" theme to see if that matters.

BishopEmpire's profile image BishopEmpire posted 5 months ago

I agree...this is very odd and extremely frustrating. I've tried reverting back to a v9.3 release but that didn't resolve my issue.

Changed back to WINDOWS (default) theme.

1 attachment(s):
  • Heidi_UpScale_HighDPI_v10-1-0-5487_02
ansgar's profile image ansgar posted 5 months ago

One more idea: did you probably set a custom DPI value for your HeidiSQL taskbar icon? See attached screen.

1 attachment(s):
  • dpi-custom-settings
dasmod's profile image dasmod posted 4 months ago

Hi, I had the same problem (resolution:3200x1800 and scale and layout: 250%.)

In order to fix the issue on 10.1.0; I changed the style theme to "windows" and as angsar suggested went to Compatability > Change High DPI settings and marked High DPI scaling override to: System (Enhanced).

This fixed the issue.

Please login to leave a reply, or register at first.