Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

After upgrade from 9.3 to 9.4.0.5152 in wine the session-manager is empty - only after restart

kai's profile image kai posted 3 years ago in Installation Permalink

Hi there,

I have no idea if this is a bug or only a temporary problem or a problem 50 cm in front of the screen...

I use HeidiSQL with wine (wine-1.6.2) under Debian (Wheezy - 8). After upgrading with HeidiSQLs upgrade-function everything worked like a charm - HeidiSQL restarted itself after the upgrade and I could double click on a session. But after restarting the PC once (or twice? Don't know...) the sessions are all gone - which seems to be weird, because they are still visible in the wine-registry file:

cat .wine/user.reg | grep -i HeidiSQL

--> shows all entries of sessions.

Could I repair this one with $foo or am I in the need to recreate all 20 sessions?

Kind regards

Kai

ansgar's profile image ansgar posted 3 years ago Permalink

I'm not sure here. Can you confirm the sessions are in HKEY_CURRENT_USER\Software\HeidiSQL\Servers\ ?

kai's profile image kai posted 3 years ago Permalink

The user.reg says:

All keys relative to \\User\\S-1-5-21-0-0-0-1000

According to winehq.org/docs/wineusr-guide/using-regedit:

user.reg

    This file contains HKEY_CURRENT_USER.

The entries look like e.g.

[Software\\HeidiSQL\\Servers\\cloud]

so it seems as if I could confirm your post.

Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
henrymanager's profile image henrymanager posted 3 years ago Permalink

Hi,

In the table definition tab, HeidiSQL shows all the columns with their datatype, length, comment etc.

For SQL server, there's no such comment column property. Instead they have a description property.

Trying to add comment to a column using the HeidiSQL interface throws error.
Already existing description for that column does not show up anywhere in the table information tab.
kai's profile image kai posted 3 years ago Permalink

Henry, please open a new topic as your question has nothing to do with the wine installation / session thing and include, what "SQL server" means. There is a bunch of SQL servers out there... ;-)

Thanks!

Kind regards Kai

ansgar's profile image ansgar posted 3 years ago Permalink

Getting back to your issue, kai: The "cloud" session path in your registry looks good. So they're not entirely lost at least.

I'm not so familiar with Wine, however, here comes another guess: a quite popular explanation to a variety of read/write problems is a privilege issue. Can you confirm the user which runs heidisql.exe can also access the user.reg file?

ansgar's profile image ansgar posted 3 years ago Permalink

Ah, and one more thing: In File > "Import settings file", you can try to import a .reg file (select "Registry file" type in the dialog. The file you need there must of course contain the sessions in a valid registry format. Probably you can use some tool to export the whole Software\HeidiSQL\ from your user.reg and import that in HeidiSQL?

kai's profile image kai posted 3 years ago Permalink

This issue has been solved. The problem was caused by $whatever, so HeidiSQL has been installed to the wrong wineprefix (/opt/irfanview/), where a user.reg resides which has no entries for sessions. The session entries have been in the ~/.wine/user.reg file. This issue tends to have nothing to to with HeidiSQL ;-)

I solved the issue as follows (all from ~), e.g. /home/kai

  • sudo WINEPREFIX="/opt/heidisql" wine wineboot
  • sudo chown $(whoami):$(whoami) /opt/heidisql
  • WINEPREFIX="/opt/heidisql" wine ./Downloads/Heidisql_installer-blablubb.exe (which refers to the latest installer)
  • beiing the lazy b... I just copied the file: cp .wine/user.reg /opt/heidisql/user.reg -v
  • correcting the launcher: sudo find / -iname heidisql.desktop
  • changing the exec-entry, so that the WINEPREFIX is correctly set: Exec=env WINEPREFIX="/opt/heidisql" wine C:\\windows\\command\\start.exe /Unix /opt/heidisql/dosdevices/c:/users/Public/Start\ Menu/Programs/HeidiSQL/HeidiSQL.lnk

Thanks for investigating.

Kind regards

Kai

Please login to leave a reply, or register at first.