Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Connection parameters to PostgreSQL

dcherk's profile image dcherk posted 3 years ago in Creating a connection Permalink

I understand that PostgreSQL support is experimental, but I figured I would ask anyways!

I am connecting to my local PostgreSQL db with the following command-line:

C:\>psql postgres://my_user:my_password@localhost:5433?options=--search_path% 3Dmy_path

However, I can't seem to figure out how to specify the same parameters in Heidi's connection manager.

Any suggestions?

Thanks, DC

ansgar's profile image ansgar posted 3 years ago Permalink

What about that?

1 attachment(s):
  • postgresql-sample-connection
dcherk's profile image dcherk posted 3 years ago Permalink

Ansgar:

The screen capture above does not have the "options" parameter. That's the main thing I am having problems with.

Thanks, DC

Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 3 years ago Permalink

Well, but it has a "Settings" tab, which is technically quite the same. See the "Database" input box.

dcherk's profile image dcherk posted 3 years ago Permalink

The "database" field specifies the database, not the "search_path" option -- which is different.

I am getting the sense that the only possible connection parameters are the ones in the Settings tab, and there is nothing else that I have missed.

Thanks, DC

ansgar's profile image ansgar posted 3 years ago Permalink

In fact, the "Database" setting in HeidiSQL will fire a SET search_path TO xyz query in PostgreSQL mode.

jan.karaffa's profile image jan.karaffa posted 3 years ago Permalink

Hi, I don't have admin rights to my computer so I wanted to use portable version, but got this strange error. Can you please include libpq.dll into portable version? See screenshot in attachment. thanks

1 attachment(s):
  • Capture
ansgar's profile image ansgar posted 3 years ago Permalink

The error message tells me that you're not using an official portable collection of files. Please just use the zip file from the download page. That should fix your problem.

jan.karaffa's profile image jan.karaffa posted 3 years ago Permalink

you are right, I didn't read what was on web page. I didn't unzip it and instead downloaded latest exe. My fault. thanks, it's working now.

Please login to leave a reply, or register at first.