SSH tunnel - plink.exe asks for passphrase, even if it is in settings

derddu posted 1 year ago in Creating a connection

Got weird bug in most recent stable HeidiSQL. The SSH tunnel option is somewhat erratic on two separate computers, one with 64-bit Windows 10 and one with 64-bit Windows 7.

When I try to start a SSH tunnel connection to our database, from time to time, I get a prompt for plink.exe that it wants my passphrase. This prompt only has "OK" button option, no methods to enter the passphrase.

I've entered the passphrase into connection's SSH Tunnel tab (to "Password" field).

To make it more weird, every now and then, the connection succeeds, without me changing anything in the settings. But 9 out of 10 times, I get the plink.exe dialog and connection failing as it cannot find database at localhost (as it should).

amyhughes posted 1 year ago

The passphrase doesn't go in the password field. The passphrase is needed to deal with your RSA key, not the server or datbase password. Problem is, heidi does not have a facility for entering the passphrase, so you have to use pageant, which sits resident in your system tray. You load it with your key, it asks for your passphrase, and makes it available to heidi.

I don't know why you would get inconsistent connection results. Are you sure you are connecting to the same server each time?

Please login to leave a reply, or register at first.