How to connect heidisql on IIS mysql from a remote machine win10

tocri posted 8 months ago in Creating a connection

Hi,

I install Heidisql on my IIS webserver to manage my databases (MySQL) Everything works but now i want to manage my database from my windows 10 but i don't know how to do that ?

AndyJ posted 7 months ago

So if I understand you have a server with MySQL installed, and you want to run Heidi on another machine that is running windows 10?

Perfectly possible - I do it all the time.

Install Heidi on your desktop and set the Network Type as MySQL (TCP/IP). Enter the hostname/ip address (I use the IP address) of the MySQL server. Supply the MySQL username and password you'd like to use and click on Open.

If it fails its normally because of one of or a combination of the following;

a) your firewall on the SERVER (running MySQL etc) is actively blocking the default port (assuming you are trying to connect to the server using that - which is 3306. Check the server firewall and make sure that port is being allowed access.

b) you are using the wrong username and password to connect with or it doesn't have permissions to connect.

c) you are using the wrong IP address or hostname. Open a command prompt (windows key + R, then CMD and press enter) and type in PING HOSTNAMEGOESHEREINSTEADOFTHIS or PING IPADDRESSGOESHEREINSTEADOFTHIS. You should get a series of 4 "replies" - if you do, you can rule out it's basic connectivity. If you don't then you have a basic connectivity issue - wrong hostname/ip address. There's a chance that the hostname/ip could be right and the server firewall is blocking your "pings" but if you get 4 replies make sure they match the actual server.... especially if you are doing this by HOSTNAME otherwise you could have a DNS issue (try IPCONFIG /FLUSHDNS in the command prompt window, then ping again to rule that out).

tocri posted 6 months ago

Hi,

Sorry i'm late.

When i try to connect with the network type as MySQL TCP/IP. Heidi says me immediatly this error :

Host 'x.x.x.x' is not allowed to connect to this MariaDB. the x.x.x.x is my public adress from my provider.

I try to disable the FW on my laptop but Nothing change. Tomorrow, i will try on a another PC to ee if it works.

I'm on Win10...up to date

AndyJ posted 6 months ago

Ahh!

Then your sql host provider is blocking the ports - so you'll need to speak to them to get them to open them up. To be honest though, it's a security risk to allow remote access to an sql database over the internet so you may find that they either won't do it at all.

So, speak to your provider....

AndyJ posted 6 months ago

Or - they might do it, as long as you sign/agree to stuff. Or they may just flat out refuse in which case you'll never get it to connect....

kalvaro posted 6 months ago

@tocri That message comes right from MySQL Server and should the firewall interfere it would not be able to get through.

In HeidiSQL's user manager (which I guess you can't use anyway) that'd be the "From Host" entry:

From Host

tocri posted 6 months ago

Hi thank you for tour reply. You're right, i will ask my provider.

Please login to leave a reply, or register at first.