Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Installer 9.5 - Not possible to specify installation folder

vehache's profile image vehache posted 2 years ago in Installation Permalink

Hi, It seems the windows installer doesn't allow to customize the installation folder and forces the installation on the C:\ drive. Is it possible to adapt the installer to be able to install on another drive ?

ansgar's profile image ansgar posted 2 years ago Permalink

Please retry that. I cannot reproduce that here.

1 attachment(s):
  • install-folder
vehache's profile image vehache posted 2 years ago Permalink

I don't have this step. (installer version 9.5.0.5196)

1 attachment(s):
  • Heidi
Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
kalvaro's profile image kalvaro posted 2 years ago Permalink

Is it possible such thing happens when the version is already installed and the wizard tries to upgrade?

vehache's profile image vehache posted 2 years ago Permalink

Wel, I have the version 9.4 installed on another drive and I want to let the installation on the same place. But the installer does not provide the option to define a custom installation path and force the C:.

ansgar's profile image ansgar posted 2 years ago Permalink

Did you start the installer with admin privileges?

vehache's profile image vehache posted 2 years ago Permalink

I just find a fix : uninstall the previous version and install the new one. Without previous installed version, the installer acts different and propose to adapt the instal folder. I suspect a problem within Windows 10 after the last update. Because I saw the uninstall did not work via the Windows "Applications & Programs" functionnality. I need to start the uninstall.exe found in the folder of HeidiSql.

Thanks to you guys to react so quickly. And I hope this will help others if someone has the same issue.

LutzT's profile image LutzT posted 2 years ago Permalink

I'm facing the same problem - I can't specify the installation folder. I started the installer as a "normal" user. The installer asks for admin privileges. I entered these requested privileges.

This is the only option I have, because I don't have a separate admin account I could use (due to corporate IT policy). Unfortunately I have to provide multiple HeidiSQL version. Any Idea what goes wrong? Thanks in Advance. L.

ansgar's profile image ansgar posted 2 years ago Permalink

In the meantime I could reproduce that problem. Not sure but I guess it was always this way, as I did not update the InnoSetup compiler some time.

LutzT's profile image LutzT posted 2 years ago Permalink

Indeed, Ansgar - every time I run into this problem updating HeidiSQL. And it is always difficult to solve it, because I can't update it as long as all of our users have closed HeidiSQL (because they lock files). Therefore, could you fix it, please?

Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 2 years ago Permalink

Files are locked during the setup, but that's very normal. I thought we were talking about the missing directory selection?

LutzT's profile image LutzT posted 2 years ago Permalink

Both is true - I can't select a different directory and files are locked. (And locking blocks the installation of files which are locked).

Usually I tell our users that there is a new installation on a new directory available (located on a network drive). The user can decide if he/ she wants to use the new or the old version/ directory (sometimes helpful in case of bugs). Therefore, I install all new version in separate directories...

ansgar's profile image ansgar posted 2 years ago Permalink

I just found one relevant setting in the HeidiSQL installer:

Valid values: yes or no
Default value: yes

Description: When this directive is yes, the default, at startup Setup will look in the registry to see if the same application is already installed, and if so, it will use the directory of the previous installation as the default directory presented to the user in the wizard.

Note that Setup cannot re-use settings from a previous installation that had Uninstallable set to no, since the registry entries it looks for are not created when Uninstallable is no.

ansgar's profile image ansgar posted 2 years ago Permalink

Sorry, missed that headline:

UsePreviousAppDir=yes

But this line is unchanged since 2007 - no clue why that should suddenly have more an effect than in previous versions.

LutzT's profile image LutzT posted 2 years ago Permalink

But finally the question is: Could you fix it... ;-)

ansgar's profile image ansgar posted 2 years ago Permalink

Well, I'm still considering whether this is a bug at all. Probably changing the above mentioned UsePreviousAppDir setting to no suddenly provides the directory selector again. I'm not really sure if that's a good thing for all users.

LutzT's profile image LutzT posted 2 years ago Permalink

What's the risk? The user will get an additional dialog to select a different directory. This should be fine, because that's usual behavior of an installer, right?

ansgar's profile image ansgar posted 2 years ago Permalink

According to InnoSetup's help file, setting it to yes is default behaviour. That's basically why I hesitate. Selecting a different directory will break the uninstaller, as it's not possible to delete files from previous installations I guess. Uninstalling + reinstalling works, by the way. Hmm.

Please login to leave a reply, or register at first.