Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Alias autocompletion delay

jaredt's profile image jaredt posted 5 years ago in General Permalink

Hi there,

I've noticed that when using autocompletion after an alias there is a delay of about a second before the autocomplete list appears. This means you have to wait for the list to appear before typing the first few letters. Otherwise if you start the alias and a period and type straight away, the autocomplete will never appear.

If I activate an autocompletion list manually (by pressing CTRL + space) the list appears immediately, so it seems like the delay is deliberate? Is there anyway to disable the delay so that the autocomplete list appears immediately when typing the period after an alias? This would mean I can keep typing given I know the first couple of letters of the column name.

I find the delay to be quite an interruption to my flow and hoping there's a solution! :)

Animated gif attached (the first "c." shows the delay, the second, shows that the autocomplete list does not appear when you keep typing immediately)

Cheers,

Jared

PS. Just wanted to say thank you for HeidiSQL. I use it every day and it's a brilliant piece of software. So thank for you all your hard work :)

1 attachment(s):
  • autocompletion-delay
ansgar's profile image ansgar posted 5 years ago Permalink

There is a TimerInterval property which seems responsible for that delay, and which is set to 500ms in HeidiSQL. If you create a new issue in the bugtracker, I could make this customizable in the settings dialog?

jaredt's profile image jaredt posted 5 years ago Permalink

Hi Ansgar,

Thanks for your speedy response. Your solution sounds great. I will create an enhancement request on Github for you. Thanks!

Misha v.3's profile image Misha v.3 posted 5 years ago Permalink

You can always use Ctrl + Space to open the autocomplete manually (this works in may IDE). Not sure that the timeout option is really required.

chiken's profile image chiken posted 1 month ago Permalink

Sorry to necro an old forum, but is this something that was ever implemented? I can't seem to find anything related in my preferences tab. Even when I have "Find matches in middle of entered text" enabled, HeidiSQL seems to have the same response as seen in OP's gif.

ansgar's profile image ansgar posted 1 month ago Permalink

Noone created an issue in the tracker, and I never saw the need to customize the interval myself. Feel free to create a ticket - quite makes sense.

chiken's profile image chiken posted 1 month ago Permalink

Thanks Ansgar, I submitted a feature request in the bug tracker.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.