Cannot find a usable libpg.dll on Windows Server 2016 and Windows10 Enterprise

grem1in posted 10 months ago in General

Hello,

I have encountered "Cannot find a usable libpg.dll" issue on Windows Server 2016 and Windows 10 Enterprise. Here are some setup details:

HeidiSQL versions tested:

  • HeidiSQL 9.5.0.5226 (x32, x64, Portable)
  • Windows Server 2016 Base, Windows 10 Enterprise

Both Server and Desktop are running on VMs: AWS EC2 VM for server and Vagrant VirtualBox VM for Desktop version. I used this Vagrant image for the installationStefanScherer/boxes/windows_10 and standard AWS AMI for Windows Server 2016 Base (cannot post the links, so just the names of respective boxes)

Other environment details: HeidiSQL exe file is located in the same directory with libpq.dll. Location of HeidiSQL installation is in %PATH%

Steps I tried:

  • Move libs between installation done by installer and Portable installation
  • Copy libpq.dll from PostgreSQL installation

Unfortunately, I was unable to test 5068 version from related topic on this forum since it's not longer available for download

Each installation was a clean install.

I'm not a Windows guy, so I don't have much expertise how to debug it deeper. I can run whatever other tests you suggest

Regards!

Ferrissi posted 9 months ago

I had same issue 2-3 days ago on one of my VM, and I installed (I cant remember correctly, sorry) VC++ redistributable 2013 (or 2015) x64, and its solved my problem.

Please login to leave a reply, or register at first.