Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.

newest version crashes in wine

nobswolf's profile image nobswolf posted 1 year ago in General

I install HeidiSQL_9.5.0.5196_Setup.exe in Debian 9.3 with wine and it works nicely.

Then an automatic update is offered and this version crashes, see attached bugereports.

$ uname -a Linux varg 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u2 (2017-06-26) x86_64 GNU/Linux

$ wine --version wine-1.8.7 (Debian 1.8.7-2)

1 attachment(s):
nobswolf's profile image nobswolf posted 1 year ago

In a new installation I just noticed another error, see attachment here.

The mentioned path exists and is writable.

1 attachment(s):
  • Bildschirmfoto_2018-03-03_19-33-25
ansgar's profile image ansgar posted 1 year ago

No clue why that happens. You can look at the bug tracker, there are some Wine issues, but none of them match to your callstack and/or to the screenshot.



Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.
BitScout's profile image BitScout posted 1 year ago

I had the same problem under Ubuntu 16.04 LTS, only the stable version from December was working last time I tested (a few weeks ago).

ansgar's profile image ansgar posted 1 year ago

Did you overwrite Wine's native Direct2D library as stated on the download page?

BitScout's profile image BitScout posted 1 year ago

I seem to have overlooked that, I'll test tomorrow, thanks!

BitScout's profile image BitScout posted 1 year ago

Works fine, thanks!

Please login to leave a reply, or register at first.