Major Connectivity Issue - Debian 9 on AWS

Darrin Ward posted 3 weeks ago in General

Hi there,

I have been a Heidi user for about 8 years, my first post here as proof (when I was moving back from OSX to Windows): heidisql dot com /forum.php?t=6240#p6243 (I can't post http links yet)

Love the product and all that you guys do, so don't assume this feedback as an attack.

I've used heidi with maybe 50-100 servers over the years with no problems (various nix flavors), however I recently needed to migrate from Rackspace to Amazon AWS. Both using Debian 9 with MariaDB, however with the Debian on AWS I get an error 10061 (SSH password error at the nix user level, not the MySQL level). I have triple verified that the password is correct by logging in via SSH from a remote host via. SSH and using the MySQL Workbench with SSH tunnel. I've tailed the /var/log/auth.log file on the server and it confirms the PAM password issue while trying to connect via Heidi.

I get prompted for a password (or, at least, notified of the prompt), but there is no way to enter a password. Please see attached screenshot. And, after I click to continue I receive the 10061 error.

The username and password is 100000% correct, copied and pasted at the very same time to all of these applications, so the issue is certainly isolated to HeidiSQL.

In tailing the server logs I see there is a password fail attempt before the prompt, so I guess either the password is not being sent or the wrong password is being sent. Another possibility is encoding or something (but that would be over my head).

Unfortunately, until this is resolved, I shall have to use the MySQL workbench.

Thank you

1 attachment(s):
  • Capture
ansgar posted 3 weeks ago

One thing which is often misunderstood is where you have to put the password for MySQL/MariaDB and the one for your SSH connection. Be sure you have the MySQL/MariaDB password into the "Settings" tab, and the SSH password into the "SSH tunnel" tab. Same goes for the username.

Darrin Ward posted 3 weeks ago

Sorry, my screenshot was misleading - I should have had the SSH tunnel tab in view, but I was principally trying to show the password prompt. The ssh/mysql passwords were used in the correct places.

Also I would note that on Debian on AWS they have PasswordAuthentication defaulted to "no" (meaning no password logins, only PubKeys)... However this setting was also changed, so it's not that either (as verified by successful logins with putty and MySQL workbench)

Please login to leave a reply, or register at first.