Failure to connect

TwoTerriers posted 3 months ago in General


Two weeks ago I installed HeidiSQL. It connected with the database without problem.

It is now unable to connect (Error 10060).

Nothing has changed.

I have installed HeidiSQL on a different machine - same error.

I have the latest version.

I can however connect through the related website and view, list and update entries within the database. This tells me that the username, database name, password and host name are all valid.

Logic says to me that the problem is with HeidiSQL.

Any suggestions would be much appreciated.


ansgar posted 3 months ago

What message comes along with "error 10060"?

TwoTerriers posted 3 months ago


Thanks for getting back to me.

The message is "Can't connect to MySQL server on '' (10060)".



ansgar posted 3 months ago

Ok, from :

The error (2003) Can't connect to MySQL server on ' server ' (10061) indicates that the network connection has been refused. You should check that there is a MySQL server running, that it has network connections enabled, and that the network port you specified is the one configured on the server.

Though your error number is different: 10060 (not 10061). Well, I guess it's basically the same: your client computer is not able to connect to the MySQL/MariaDB server on port 3306. Or the MySQL service is not running properly on the server. Or the MySQL service blocks all network connections.

TwoTerriers posted 3 months ago

Sorry, but I'm struggling to understand why I can connect via the website, but can't connect via heidisql.

Meanwhile I am taking things up with the server owner.



ansgar posted 3 months ago

I suppose the computer which runs your website is not the computer which runs HeidiSQL, or? In that case privileges on the MySQL server can be the cause. Also, the server may not except network connections from outside at all.

TwoTerriers posted 3 months ago

Thanks again.

I'm pretty certain that there is a problem with server permissions. They appear to have changed. I'm taking it up with the server owner.

Consequently, I'll terminate this thread.

Thanks for all your input.

TwoTerriers posted 2 months ago


Just to wrap this up, it turns out that to connect to the server hosting the database, it needed my ip address. And for reason known only to BT (my broadband provider), it keeps changing my ip address.

By using a VPN (which I can do) my ip address is fixed.

Anyway - problem solved.

Thanks to all

ansgar posted 2 months ago

Thanks for your feedback! Glad you fixed it.

Please login to leave a reply, or register at first.