Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Export to CSV NULL turn to \N but when importing from CSV \N turn to text "\N" instead of NULL

harishashim's profile image harishashim posted 1 year ago in Import/Export Permalink

As per the title. Is this a bug?

I have to change all \N to NULL in the csv file to successfully import that CSV with the proper NULL value

ansgar's profile image ansgar posted 1 year ago Permalink

What did you enter (or left) in the "NULL value" text field of the export dialog?

harishashim's profile image harishashim posted 1 year ago Permalink

Must be \N since the output exported is \N

Thanks. That is a useful tips for exporting.

But IMHO more on topic is about importing. And I did not see any NULL related option in the CSV import dialog.

ansgar's profile image ansgar posted 1 year ago Permalink

String values of "NULL" should be imported as NULL value.

Please login to leave a reply, or register at first.