Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

HeidiSQL hangs on this upload query: LOAD DATA LOCAL INFILE

WaveLength's profile image WaveLength posted 9 months ago in General Permalink

A query that I've used for years in HeidiSQL no longer works -- since I upgraded to Windows 10, from Windows 8.1. HeidiSQL now uploads only about 39,000 records, and then goes dormant, but the entire dataset actually contains about 120,000 records. There are no error messages; the progress bar just stops.

For further testing, I've reverted to the exact HeidiSQL version (9.5.0.5196, 64 bit) and dataset that I used successfully last December, but even that fails. (I'm using SSH tunneling to upload tab-delimited text data to a MyISAM table on a remote Linux web server.)

My other queries run fine on the remote server. It's just the LOAD DATA LOCAL INFILE query that doesn't complete. I wonder if something is timing out. In the Session Manager, I've set the plink.exe timeout to 30, and "Ping every X seconds" to 5.

Are there any other settings I should check? Is there a way to diagnose this?

I would sincerely appreciate any suggestions about how to get my upload query working again.

Thanks.

WaveLength's profile image WaveLength posted 9 months ago Permalink

A long time after the query went dormant, I looked at the HeidiSQL log file, and it lists no activity at all, after the LOAD DATA query. Apparently, after importing some records, HeidiSQL just stopped. This is what phpMyAdmin used to do, before I switched to HeidiSQL.

Next, I tried the same query in TablePlus, which is a basic MySQL client, and after about 5 minutes, it gave this error message: "Lost connection to MySQL server during query". I wonder what could be causing this.

WaveLength's profile image WaveLength posted 9 months ago Permalink

Just now, I got the same result in SQLectron, which is another basic MySQL client. Here's the error message:

Connection lost: The server closed the connection.

fatal: true

code: PROTOCOL_CONNECTION_LOST

name: Error

WaveLength's profile image WaveLength posted 9 months ago Permalink

As it turns out, the web server was partially blocking my IP address. After the server admin fixed that, I stopped losing the connection. Unfortunately, data transfer still seems unusually slow.

Please login to leave a reply, or register at first.