Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.

Multiple monitor

Roelie's profile image Roelie posted 7 months ago in General Permalink

Hello

I work with two extra monitors if I open HeidiSQL on the main monitor it looks ok but when I move it to another monitor you see that the font is to big the characters get over each other.

The font in the menu is OK and also the SQL at the bottom "SHOW DATABASES"

Is there a way I can solve this.

Roelie.

1 attachment(s):
  • heidsql
ansgar's profile image ansgar posted 7 months ago Permalink

The problem comes in when you move the window to a screen with a different DPI setting. I'm nearly sure that was posted as a bug in the tracker, and I marked it with a high-dpi label.

A workaround is to move the window to where you want it to be, then exit HeidiSQL, and restart it, and it should be starting on the previous screen.

Roelie's profile image Roelie posted 7 months ago Permalink

I have solved it. Now it works fine for me, I was used to MYSQL Workbench, but that one does not work with MariaDB. Below the issue 213 on github HeidSQL in which I found it, see also the attachment how I changed it. (Windows 10)

  • energizer77 commented on Apr 10, 2018 For me this helped: Go to the heidisql.exe file => Properties => Compatibility => Check "Override high DPI scaling behaviour" and selecting "System (Enhanced)"
1 attachment(s):
  • HeidiSQL-change-DPI

Please login to leave a reply, or register at first.