Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

trying to connect to MSSQL server using named pipe in HeidiSQL

raphael75's profile image raphael75 posted 3 months ago in General Permalink

I'm trying to connect to a MSSQL server in our office from my local desktop using HeidiSQL. I am able to connect to this server with both SQL Server Management Studio and ODBC with no problems. The connection uses integrated Windows authentication. I installed the MS OLE DB SQL 18.2.2.0 x64 driver. My settings in HeidiSQL are:

network type: Microsoft SQL Server (named pipe)

library: MSOLEDBSQL

hostname: <server>\<instance>

use windows authentication is checked

every time I try to connect I get:

SQL Error (0): SQL Server Network Interfaces: Server doesn't support requested protocol [xFFFFFFFF] Login timeout expired

It doesn't tell me what protocol is being used, and I don't see any options to change it. Does "protocol" in this case refer to the library?

Is there some way to change the protocol in Heidi?

ansgar's profile image ansgar posted 3 months ago Permalink

Yes, of course. Try tcp ip instead of named pipe in the network type drop down.

raphael75's profile image raphael75 posted 3 months ago Permalink

When I tried TCP/IP (leaving everything else the same) I get this error:

SQL Error (0): TCP Provider No connection could be made because the target machine actively refused it. Login timeout expired

I don't understand why I get this in Heidi when SSMS and ODBC can connect.

ansgar's profile image ansgar posted 3 months ago Permalink

Probably update to the latest build of heidisql, and then select the other option in the new library drop down on the session manager.

Please login to leave a reply, or register at first.