Installing on Microsoft Remote Desktop Services

marcusawerly's profile image marcusawerly posted 3 weeks ago in General Permalink

Anyone have experience with this? My users prefer Heidi Over the MS SQL Client. I don't mind them using it. It is lightweight and loads much faster. but I can't for the life of me get it to install per user. Non admin users cannot use the auto save feature if it is installed to Program Files.

Marcus

ansgar's profile image ansgar posted 3 weeks ago Permalink

Which version exactly did you install?

The auto-save feature normally saves its backup files to C:\Users\YourUserName\AppData\Roaming\HeidiSQL\. You could check if that directory has a sub directory called Backup, and whether it's writable for these users.

marcusawerly's profile image marcusawerly posted 3 weeks ago Permalink

Download HeidiSQL 10.2 Release date: 15 Jun 2019. Installer, 32/64 bit combined

I may be installing it incorrectly.

marcusawerly's profile image marcusawerly posted 3 weeks ago Permalink

[Window Title] PRODUCTION: Error

[Main Instruction] Auto-storing tab setup failed

[Content] Cannot create file "C:\Program Files\HeidiSQL\Backups\query-tab-2019-09-26_02-50-01-645.sql". The system cannot find the path specified

[OK]

[Footer] Find some help on this error (=> ecosia.org)

That is the error I keep getting.

ansgar's profile image ansgar posted 3 weeks ago Permalink

The path makes me think you have a portable.lock file, or/and a portable_settings.txt there. Please check that and remove or rename them. If you want to use the portable version, unpack it in a directory with write permissions. Even if you used the installer, that file could probably be there from a previous portable folder.

marcusawerly's profile image marcusawerly posted 3 weeks ago Permalink

That is what it was. Portable Lock and tabs.ini. I was using the installer and then adding a portable.ini settings to share the connection info with the users. I removed the connection info and just showed them how to import the settings file. Thank you!

Marcus

Please login to leave a reply, or register at first.