Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Line spacing issue in windows 10

DennisS's profile image DennisS posted 2 months ago in General Permalink

Hi

I just installed Heidi SQL on windows 10 but have an issue with line spacing - the fonts overlap each line.

I changed the font to Calibri and reduced the size but it is still not displaying correctly - see example of connection screen attached.

It is usable and works ok but it would be great to get the right display settings

Thoughts?

1 attachment(s):
  • Heidi-line-spacing
ansgar's profile image ansgar posted 2 months ago Permalink

Looks as if you have set HeidiSQL to use application controlled DPI awareness, which Heidi does no longer support, and which was always broken. Is that probably the case?

DennisS's profile image DennisS posted 2 months ago Permalink

Hi, it may be the case but honestly I don't know. I did a straightforward install of the windows download.

Just now I looked through preferences but didn't see anything obvious.

Are there any registry settings I should delete or amend?

Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
ansgar's profile image ansgar posted 2 months ago Permalink

To find out whether you customized your DPI settings for HeidiSQL:

  • rightclick your HeidiSQL icon (on the taskbar or wherever you have it)
  • then click "Properties"
  • click "Compatibility"
  • click "High DPI settings", which will show you something like this:

Description

DennisS's profile image DennisS posted 2 months ago Permalink

Thank you. None of the boxes were checked. I checked 'Override DPI ...' and selected 'system' then restarted. It displays perfectly. :-)

Thank you for your help!

ansgar's profile image ansgar posted 2 months ago Permalink

Oh, in that case I suppose you were not on the latest build, because the latest builds don't support DPI settings anyway. Perhaps you were using an older build with broken DPI support. Which version is it?

Please login to leave a reply, or register at first.