Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Export strings. The numbers are in the wrong format. Visually dot separator. And when exporting a comma.

BlackByte's profile image BlackByte posted 4 weeks ago in Import/Export Permalink

Export strings. The numbers are in the wrong format. Visually dot separator. And when exporting a comma.

I have "364,00", not "364.00"

WHY??? Fix pls

3 attachment(s):
  • HeidiSQL-export
  • -2020-01-29-13.27.59
  • -2020-01-29-13.29.19
ansgar's profile image ansgar posted 4 weeks ago Permalink

Then how is it exported, with comma, or...?

BlackByte's profile image BlackByte posted 4 weeks ago Permalink

It is necessary that there would be a "." Just as I see in the screenshot. Why is exported with ","?

Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.
BlackByte's profile image BlackByte posted 4 weeks ago Permalink

Why?

see gif pls

1 attachment(s):
  • 1195607609-1-
ansgar's profile image ansgar posted 4 weeks ago Permalink

Ok, I see you disabled "Local number format" for the grids, but the comma seems to be your local setting for the decimal separator. This is a Windows setting, which can be changed in the control panel's region settings.

When exporting in "Excel CSV", HeidiSQL uses your local decimal separator, as this is normally expected by your Excel too. If you want the native dot as decimal separator, use the "Delimited text" export format.

BlackByte's profile image BlackByte posted 4 weeks ago Permalink

Thanks. I will try to.

The problem just arose with the Google spreadsheets application (tables). When I inserted such a value (with a comma) it did not perceive it as a number.

BlackByte's profile image BlackByte posted 4 weeks ago Permalink

I changed in the Windows settings but the problem remained. :(

1 attachment(s):
  • 1258435546-1-
BlackByte's profile image BlackByte posted 4 weeks ago Permalink

"Delimited text" works fine

Please login to leave a reply, or register at first.