Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Cannot Setup Postgresql Connection - Library is not in the List

mojosound's profile image mojosound posted 4 weeks ago in General Permalink

I downloaded the current installer as well as the current portable edition. When I try to setup a connection to a Postgresql database there is no option for the libpq library in the dropdown. There is only mariadb and 2 mysql libraries to choose from. This is the same behavior when I run the installed version and the portable version on my Windows 10 laptop. If I leave the library blank then I get an error on open that says a file does not exist. It looks like the library field cannot be blank. Is there some setting that I need for using Postgresql (TCP/IP) that I have not found?

Installed version is 10.3.0.5771 (64 bit) installed on Windows 10 Home (1903).

ansgar's profile image ansgar posted 4 weeks ago Permalink

I fixed that short after the last release, so the latest build has a fix for that.

Also, if you once save the session, select a different one and then again your PG connection, the dropdown should also show the right library.

mojosound's profile image mojosound posted 4 weeks ago Permalink

Thanks. I downloaded and installed the nightly build and it is there. Looking forward to trying it out and hopefully getting some work done :).

Please login to leave a reply, or register at first.