Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

marking only all tables during export

MacDknife's profile image MacDknife posted 2 weeks ago in Import/Export Permalink

Hi! Keep up the good work! I have a small issue with marking all my tables in a database when exporting. I often export from my live server to my local server to get the latest changes in data. Unfortunately, although the tables have the same names, the databases do not. On the export page, if I mark all my tables in the database, the database is automatically marked as well, which results in another database being created locally and all the tables inserted there instead, when I run the file in the "Quest" tab.

Sure, I can edit the file and replace the database name, but it would be nice to be able to just mark only the tables, without automatically including the database. I would even like to suggest being able (if possible) to hold down the SHIFT key when marking all the tables (like marking a file list in Windows Explorer). A tiny issue I know, but I hope it can be fixed.

In these otherwise dark times, keep safe and healthy! Regards to all, MacD

ansgar's profile image ansgar posted 2 weeks ago Permalink

You could uncheck the create database option.

Also, you could directly export to your local database, with a file:

Description

Please login to leave a reply, or register at first.