Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.

Double Quotes now being added to Export Grid Rows

CFlath's profile image CFlath posted 2 months ago in Import/Export Permalink

In a recent build, a change was made wrapping the first column header in double quotes (") which creates a manual requirement to remove them when importing into other tools. Perhaps this was done to resolve other issues, but it becomes an inconvenience in data export operations.

Hopefully this was just a minor oversight and is not required for other functionality.

Thanks for the read.

ansgar's profile image ansgar posted 2 months ago Permalink

Which output format did you use? I was just using SQL Inserts, but the column headers naturally get a backtick on MariaDB, not a doublequote.

CFlath's profile image CFlath posted 2 months ago Permalink

I was doing a handful of simple "Excel CSV" exports from MySQL. Once exported, the first column header now comes across as "Customer" with double quotes. All other columns behave normally as they used to.

Thank you for the reply.

ansgar's profile image ansgar posted 2 months ago Permalink

This is what I just got with the latest HeidiSQL build, with Excel CSV output:

"rev_id"   "created"   "id"    "pk_value"  "status_id"
"5" "2010-08-15 22:37:00"   "1" "167"   "1"
"9" "2012-01-31 10:30:31"   "1" "0" "1"
"10"    "2012-01-31 10:32:00"   "1" "0" "1"

Looking at the code, I saw double quotes are used since several years for the Excel output. Can you somehow paste the output of an earlier version which does not have double quotes?

TorukCamanbay's profile image TorukCamanbay posted 1 month ago Permalink

Hi,

Some problem in clipboard export. Currently clipboard export have invisible character before first (") character. Here a lot of this character between quotes > ""

currently version clipboard export: "first row" "Customer_Active" "CustomerPlanType_Id" "1898" "1" "1" "11491" "1" "1"

version 6047 clipboard export: "first row" "Customer_Active" "CustomerPlanType_Id" "1898" "1" "1" "11491" "1" "1"

1 attachment(s):
  • invisible-character-on-export-clipboard
ansgar's profile image ansgar posted 1 month ago Permalink

You may have to select ANSI encoding when exporting with a new HeidiSQL build.

See issue #1077 - Excel export now does not force ANSI encoding. Instead, in UTF-8 mode, it inserts a BOM at the very beginning of the file, which is required by newer Excel versions. Using ANSI encoding, you can fix that for an older Excel version.

CFlath's profile image CFlath posted 1 month ago Permalink

As TorukCamanbay mentioned, I have now seen/detected the BOM character prior to the quotes in the first column. When copying from Clipboard, the setting is already ANSI and cannot be changed.

Description

kthanid's profile image kthanid posted 1 month ago Permalink

Just chiming in to say that I have the same issue identified in this thread with the most recent build and, like CFlath, have confirmed that my export encoding is set to "ANSI".

ansgar's profile image ansgar posted 2 weeks ago Permalink

This was indeed an issue in HeidiSQL, and should be fixed in the next build, compiled in a few minutes.

See also this thread for some details (basically the same discussion as here)

CFlath's profile image CFlath posted 2 weeks ago Permalink

Yes, the issue is solved. Thank you for you persistence, even on little things such as this.

Please login to leave a reply, or register at first.




Ads were blocked - no problem. But keep in mind that developing HeidiSQL, user support and hosting takes time and money. You may want to send a donation instead.